Closed Bug 1768380 Opened 7 months ago Closed 6 months ago

Tab fonts changed color to black in built-in FF themes

Categories

(Firefox :: Theme, defect)

Firefox 100
defect

Tracking

()

RESOLVED DUPLICATE of bug 1768376
Tracking Status
firefox-esr91 --- unaffected
firefox100 --- wontfix
firefox101 --- fix-optional
firefox102 --- affected

People

(Reporter: paulsawyer1111, Assigned: sfoster)

References

(Regression)

Details

(Keywords: regression)

Attachments

(3 files)

Attached file LOG.txt

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:100.0) Gecko/20100101 Firefox/100.0

Steps to reproduce:

The only step to reproduce it on my system is open FF.

Actual results:

Tab font changed color to black in built-in FF themes
This what it looks like
https://i.imgur.com/53RNkjV.png?1

Expected results:

This is how it should be
https://i.imgur.com/1zL2LFU.png?1

I tried System theme, Dark theme and Light theme - the font remains the same. Then I tried installing custom addon themes, and the fonts did change color.
I ran Mozregression by recommendation of a Reddit user, but I'm not sure what results of that session I should share exactly, so I attach the log file of it.

The Bugbug bot thinks this bug should belong to the 'Core::Layout: Text and Fonts' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Layout: Text and Fonts
Product: Firefox → Core
Component: Layout: Text and Fonts → Theme
Product: Core → Firefox
Regressed by: 1753767

What setup do you have on Windows to see that? Also what windows version? Do you have a high contrast theme or something else? I don't know how to get such tab bar background without themes.

Anyways that looks pretty bad, thanks for filing!

Flags: needinfo?(paulsawyer1111)

Set release status flags based on info from the regressing bug 1753767

(In reply to Emilio Cobos Álvarez (:emilio) from comment #2)

What setup do you have on Windows to see that? Also what windows version? Do you have a high contrast theme or something else? I don't know how to get such tab bar background without themes.

Anyways that looks pretty bad, thanks for filing!

Win8.1 for one language, x64 (yes, I'm a weirdo). This is the general system layout that you set up in Personalization menu for all apps and windows, so basically system theme.

Flags: needinfo?(paulsawyer1111)

:sfoster, since you are the author of the regressor, bug 1753767, could you take a look?
For more information, please visit auto_nag documentation.

Flags: needinfo?(sfoster)
Has Regression Range: --- → yes

(In reply to Paul from comment #4)

Win8.1 for one language, x64 (yes, I'm a weirdo). This is the general system layout that you set up in Personalization menu for all apps and windows, so basically system theme.

Can you elaborate on that? Are you using one of the pre-installed windows appearance/personalization 'themes". Or have you configured some of the different window element colors yourself? I don't have windows 8.1 handy, but looking at windows 7 I see options like "Active Titlebar", "Application Background" where its possible to pick a color. And we try to use these system colors in the appropriate place in Firefox. As these are similar on windows 10, I assume they are also similar in windows 8.1. It would help me to know what your configuration looks like in a bit more detail so I can accurately reproduce and start tracking down what I broke and how to fix it.

Flags: needinfo?(sfoster) → needinfo?(paulsawyer1111)
Assignee: nobody → sfoster
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

This is general looking Personalization menu for Win8.1 - mine is the same, just with a darker color.
https://i.ytimg.com/vi/nCmLdmY7sbU/maxresdefault.jpg
"Color" is the only thing I have configured there - it sets color for task panel and window tabs. I don't know if there are any options to change the font color for headlines in Win8.1 (nor have I ever seen "Active Titlebar" or "Application Background" anywhwere in settings), so I never changed them specifically; the headlines in Explorer have always been lighter-dark-grey, like in the picture here, and the fonts in FF - white, like in the picture in OP.

Flags: needinfo?(paulsawyer1111)

This is the image from comment #7, attaching here to make sure we don't lose it.

Thanks reporter, I think that gives me enough to go on.

This is the image from comment #0, attaching here to ensure we don't lose it.

See Also: → 1503368

FF 100.0.1, Alpenglow theme not affected by this bug.

The severity field is not set for this bug.
:dao, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(dao+bmo)
See Also: → 1768376

I'm not sure I'm reproducing this correctly. I have a win8 VM, but I don't know exactly which colors got set to what to arrive at the state shown in comment 9.

The patch for bug 1768376 landed and should be in Firefox 102 - which is currently Beta. I suspect this will fix the issue. Are you still able to reproduce this problem in Nightly or a current Beta?

Flags: needinfo?(paulsawyer1111)

(In reply to Sam Foster [:sfoster] (he/him) from comment #13)

I'm not sure I'm reproducing this correctly. I have a win8 VM, but I don't know exactly which colors got set to what to arrive at the state shown in comment 9.

The patch for bug 1768376 landed and should be in Firefox 102 - which is currently Beta. I suspect this will fix the issue. Are you still able to reproduce this problem in Nightly or a current Beta?

102 Works fine in Nightly, the fonts are back to white.

Flags: needinfo?(paulsawyer1111)

(In reply to Paul from comment #14)

102 Works fine in Nightly, the fonts are back to white.

Thanks for confirming. I'll close this as a duplicate of bug 1768376 as it looks like it was the same underlying problem, and that's where the patch to fixed it landed.

Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Flags: needinfo?(dao+bmo)
Resolution: --- → DUPLICATE

(In reply to Sam Foster [:sfoster] (he/him) from comment #15)

(In reply to Paul from comment #14)

102 Works fine in Nightly, the fonts are back to white.

Thanks for confirming. I'll close this as a duplicate of bug 1768376 as it looks like it was the same underlying problem, and that's where the patch to fixed it landed.

*** This bug has been marked as a duplicate of bug 1768376 ***

OK, thank you for fixing this!

You need to log in before you can comment on or make changes to this bug.