Closed Bug 1771653 Opened 3 months ago Closed 3 months ago

Contact picture in message header not properly aligned

Categories

(Thunderbird :: Toolbars and Tabs, defect)

Thunderbird 102
defect

Tracking

(thunderbird102? fixed)

RESOLVED FIXED
103 Branch
Tracking Status
thunderbird102 ? fixed

People

(Reporter: ak.bugzilla, Assigned: aleca)

References

(Blocks 1 open bug)

Details

Attachments

(6 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/101.0.4951.64 Safari/537.36 Edg/101.0.1210.53

Steps to reproduce:

Select the option to show the contact picture in the mail header. This option was introduced in bug 1556261. Don't select the option to show the sender's e-mail address below the display name.

Actual results:

The contact picture is not properly aligned to the text.

Expected results:

Move the contact picture some pixels towards the top.

Assignee: nobody → alessandro
Status: UNCONFIRMED → NEW
Ever confirmed: true

Thanks for the report.
Could you please tell me the Density setting and Font Size of the app you're currently using?
Thanks.

Flags: needinfo?(ak.bugzilla)
Status: NEW → ASSIGNED

My settings are:
Density: Compact
Font Size: 12 px

Flags: needinfo?(ak.bugzilla)

This will need 102 uplift.

Flags: needinfo?(rob)
Target Milestone: --- → 103 Branch

Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/173017440f3b
Better align the message header profile picture. r=Paenglab

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED

Comment on attachment 9278681 [details]
Bug 1771653 - Better align the message header profile picture. r=Paenglab

[Triage Comment]
Approved for 102.0b1.

Flags: needinfo?(rob)
Attachment #9278681 - Flags: approval-comm-beta+

Strange. If there is no contact picture in the address book, the placeholder is in the right position. But with a contact picture, it now moves to the top.

What's the placeholder?
Would you be able to share a screenshot with the issue?

Attached image with-image.png

I haven't tested with an image. :-(
Here a screenshot with image as avatar. I hovered to see the boundaries of the button better.

Attached image TB contact picture.png

See the attached screenshot of the same mail when there is no picture (left) and a picture (right) stored in the address book. Screenshots taken with "touch" density for better visibility, but the behavior is the same for other densities.
The placeholder is the circle with a single letter when there is no contact picture in the address book.

Ah! I see the problem!

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached image header-alignment.png (obsolete) —

The new patch should fix everything, tested with all scenarios.
Missing something?

Attached image header-alignment.png
Attachment #9278970 - Attachment is obsolete: true

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/888918704753
Fix message header profile picture alignment. r=Paenglab

Status: REOPENED → RESOLVED
Closed: 3 months ago3 months ago
Resolution: --- → FIXED

Comment on attachment 9278965 [details]
Bug 1771653 - Fix message header profile picture alignment. r=Paenglab

[Approval Request Comment]
Regression caused by (bug #): bug 1556261
User impact if declined: Wrong alignment of elements when customizing the message header UI
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9278965 - Flags: approval-comm-beta?

Resetting 102 status so the follow-up doesn't get missed in beta2.

Comment on attachment 9278965 [details]
Bug 1771653 - Fix message header profile picture alignment. r=Paenglab

[Triage Comment]
Approved for beta

Attachment #9278965 - Flags: approval-comm-beta? → approval-comm-beta+
Blocks: tb102found
You need to log in before you can comment on or make changes to this bug.