Closed Bug 1777304 Opened 2 months ago Closed 1 month ago

Cannot edit an entry in address book when there are two emails

Categories

(Thunderbird :: Address Book, defect)

Thunderbird 102
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1777214

People

(Reporter: bernat, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Firefox/102.0

Steps to reproduce:

  1. In Fastmail, add a second email address to an entry.
  2. Synchronize in Thunderbird

Actual results:

I can see the two email addresses, but hitting "Edit" does nothing. In the console, I get:

20:11:14.698 Uncaught TypeError: defaultEmail is undefined
    getDefaultEmail chrome://messenger/content/addressbook/edit/edit.js:313
    updateEmailHeading chrome://messenger/content/addressbook/edit/edit.js:294
    updateView chrome://messenger/content/addressbook/edit/edit.js:172
    set vCardProperties chrome://messenger/content/addressbook/edit/edit.js:110
    editCurrentContact chrome://messenger/content/addressbook/aboutAddressBook.js:2858
    _onClick chrome://messenger/content/addressbook/aboutAddressBook.js:3180
    handleEvent chrome://messenger/content/addressbook/aboutAddressBook.js:2313
edit.js:313:5

In Fastmail, a default email address is defined correctly (this is a dropbox, from the interface point of view, this is not possible to not define a default address email).

Expected results:

I should be able to edit the message.

Blocks: tb102found

(In reply to jodelhodel32 from comment #1)

See https://bugzilla.mozilla.org/show_bug.cgi?id=1777214

Please use this syntax for auto-linking: bug 1777214

Should be fixed - Vincent, can you confirm on 102.0.1 or higher?

Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1777214

I am running 103.0b4 and it is indeed fixed. Thanks!

You need to log in before you can comment on or make changes to this bug.