Closed Bug 1777622 Opened 2 months ago Closed 1 month ago

All SubDialogs don't resize when the global font size is larger, content is cut off

Categories

(Thunderbird :: Theme, defect, P1)

Thunderbird 102

Tracking

(thunderbird_esr91 unaffected, thunderbird_esr102+ fixed, thunderbird103? fixed)

RESOLVED FIXED
104 Branch
Tracking Status
thunderbird_esr91 --- unaffected
thunderbird_esr102 + fixed
thunderbird103 ? fixed

People

(Reporter: brianmporter82, Assigned: aleca)

References

(Blocks 1 open bug)

Details

(Whiteboard: [TM:102.0.3])

Attachments

(2 files)

Attached image 2022-06-30_18h57_54.png

Steps to reproduce:

View - Font Size - Increase Font Size (3 times)
Settings - General - Incoming Mail - "CUSTOMIZE" button

Actual results:

The text no longer fits in the popup window. The "OK" and "CANCEL" buttons are pushed off the bottom of the window.

Expected results:

Popup window should scale size with the increase in font size

Blocks: tb102found
Severity: -- → S4
Component: Untriaged → Theme
Assignee: nobody → alessandro
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9284072 - Attachment description: Bug 1777622 - Resize the Preferences > General > Incoming > Customize subdialog to handle large font size. r=#thunderbird-reviewers → Bug 1777622 - Make sure all subdialogs are properly resized to account for font size variations. r=#thunderbird-reviewers
Priority: -- → P1
Summary: Customize New Mail Alert popup text doesn't fit in the box → All SubDialogs don't resize when the global font size is larger, content is cut off
Attachment #9284072 - Attachment description: Bug 1777622 - Make sure all subdialogs are properly resized to account for font size variations. r=#thunderbird-reviewers → Bug 1777622 - Make sure all subdialogs are properly resized to account for font size variations. r=darktrojan
Target Milestone: --- → 104 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/7a0982aee630
Make sure all subdialogs are properly resized to account for font size variations. r=Paenglab,darktrojan

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED

Comment on attachment 9284072 [details]
Bug 1777622 - Make sure all subdialogs are properly resized to account for font size variations. r=darktrojan

[Approval Request Comment]
Regression caused by (bug #): -
User impact if declined: All subdialogs in Address Book, Preferences, and Account Settings don't resize if the global font size is too large
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): it should be low as the fix only forces the subdialog to resize on opening if the global font size is altered.

Attachment #9284072 - Flags: approval-comm-esr102?
Attachment #9284072 - Flags: approval-comm-beta?
Whiteboard: [TM:102.0.3]

Comment on attachment 9284072 [details]
Bug 1777622 - Make sure all subdialogs are properly resized to account for font size variations. r=darktrojan

[Triage Comment]
Approved for beta

Attachment #9284072 - Flags: approval-comm-beta? → approval-comm-beta+
Duplicate of this bug: 1779260

As bug 1779260 shows, this can make entire dialogs like the edit list dialog completely unusable, which isn't S4.

Severity: S4 → S2

Comment on attachment 9284072 [details]
Bug 1777622 - Make sure all subdialogs are properly resized to account for font size variations. r=darktrojan

[Triage Comment]
Approved for esr102

Attachment #9284072 - Flags: approval-comm-esr102? → approval-comm-esr102+
You need to log in before you can comment on or make changes to this bug.