Closed Bug 1778353 Opened 5 months ago Closed 5 months ago

"Compact Folders" corrupts INBOX.msf/INBOX data, TB v102.0 (64-bit)

Categories

(Thunderbird :: Folder and Message Lists, defect, P1)

Thunderbird 102

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1777454

People

(Reporter: daniel.q.bandera, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/102.0.5005.115 Safari/537.36 OPR/88.0.4412.53

Steps to reproduce:

Did an "Empty Trash" followed, once completed, by a "Compact Folders".

Renamed INBOX.msf which forced Thunderbird to download all INBOX.msf and INBOX data from my IMAP server which restored proper rendering of e-mail.

User Agent Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:102.0) Gecko/20100101 Thunderbird/102.0

Actual results:

e-mail was displayed as raw HTML/EML instead of being properly rendered.

Expected results:

NO corruption of INBOX.msf/INBOX should occur on a "Compact Folders" action.
e-mail should continue to be rendered properly after a "Compact Folders" action.

Priority: -- → P1

Dan, can you check if bug 1777776 looks like your issue? Looks similar to me.
Also: what type are affected accounts, POP or IMAP?

Flags: needinfo?(daniel.q.bandera)
See Also: → 1777776

(In reply to Dan from comment #0)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/102.0.5005.115 Safari/537.36 OPR/88.0.4412.53

Steps to reproduce:
Did an "Empty Trash" followed, once completed, by a "Compact Folders".

For perfection, one line per numbered step pls :-)

  1. Empty Trash
  2. once completed, Compact Folders

Renamed INBOX.msf which forced Thunderbird to download all INBOX.msf and INBOX data from my IMAP server which restored proper rendering of e-mail.

I understand that this is a repair step, not part of the steps to reproduce the bug.

Severity: -- → S1
Component: Untriaged → Folder and Message Lists
Flags: needinfo?(daniel.q.bandera)

Hi Thomas,

Although bug 1777776 looks similar, in my case the raw HTML/EML displayed appeared to be from the e-mail selected. That is, I believe it was the e-mail unrendered. Sorry I did not take a screenshot.

And yes, your understanding that
"Renamed INBOX.msf which forced Thunderbird to download all INBOX.msf and INBOX data from my IMAP server which restored proper rendering of e-mail."
was a repair step, not part of the steps to reproduce the bug, is correct.
I included this information because I wanted you to know that it was all that was necessary to restore proper rendering / proper operation of Thunderbird.

My mail server is a Spectrum/Charter IMAP server.

My INBOX currently has 3,679 e-mails in it and I have attached a file with a screenshot of the file information from File Explorer.

Best,
Dan

This is probably Bug 1777454.

Can you try Daily to see if that resolves it?

I reported the similar case in bug Bug 1777738. With the release of 102.0.1, I thought it was fixed. However, I just saw the same problem again. I did a compact and then selecting messages in the inbox showed raw html for one message until I did a repair on the inbox. Previously, any time I did a compact, even if it didn't need it, I saw the corruption. Just now, I did a compact after a day of routine email work and the inbox was corrupted. The repair fixed it. Then I did another compact, right away, and the corruption did not happen. Dan reports a lot of messages in his inbox. Mine is being corrupted with just a few messages, 11 at the moment.

I did another experiment. I received a 2.4 meg message followed by a 16.5 KB message. These were messages 12 and 13. I deleted the larger message and then did a compact. The 9th message preview showed HTML from the 4th message. Thus, the corruption is happening in what should have been previously compact messages.

Once again, the Repair fixed it. However, as usual, I had to close TB three times, reopen it, and invoke Repair before the repair actually did it.

This was with 102.0.1. I tried the Daily yesterday and it was not easy. I ran the daily and then couldn't go back to 102.0.1 without a restore of my profile. This is my production machine.

(In reply to Sam from comment #7)

This was with 102.0.1. I tried the Daily yesterday and it was not easy. I ran the daily and then couldn't go back to 102.0.1 without a restore of my profile. This is my production machine.

You can run thunderbird with --allow-downgrade after the command to use the same profile with an older version.

Also: The fix for this bug is now in Thunderbird Beta 103.0b4 so you can try that as well if you like. It's up to you, of course. These fixes will eventually make their way to the next 102 minor version, but that may take another week.

Blocks: tb102found

Possibly related: #1777912

This problem is occurring on my primary Windows system so I can not afford to experiment with Daily or Beta releases.

“The patient says, "Doctor, it hurts when I do this."
The doctor says, "Then don't do that!”
― Henny Youngman

I am taking the doctor's advice and not doing that (Compact Folders), until a fix is available on the primary Release Channel.

Excellent advice! Love it!

Interesting.

Turned off the setting to automatically compact to save [X] MB space too. (I had this on without prompting.)

This bug seems to be showing up in various reports. If an automatic compact is the default setting, this bug will impact all active TBird users. Since the fix exists, shouldn't it go out at top priority?

I updated to 102.0.2 and the same bug exists.

See Also: → 1779273
See Also: → 1777912

Seems we should dupe this to bug 1777454

See Also: → 1777454

(In reply to Magnus Melin [:mkmelin] from comment #15)

Seems we should dupe this to bug 1777454

Agreed, at this point it's clear enough I think.

Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.