Closed Bug 1779025 Opened 1 month ago Closed 1 month ago

CardDAV address book contacts are not editable when having multiple E-Mail address entries but none has "PREF=1" as attribute

Categories

(Thunderbird :: Address Book, defect)

Thunderbird 102
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1777214

People

(Reporter: Lukas.Wringer, Unassigned)

References

(Blocks 1 open bug)

Details

Steps to reproduce:

I configured an existing CardDAV address book (containing contacts). (SOGo, vCard 3.0) and tried editing an existing contact with multiple E-Mail addresses.

Actual results:

Clicking on 'Edit' just does nothing.

As far as I have found this is caused by not having an entry with PREF=1.

Depending on the contact different errors are shown in console - in my test-case this message appears every time I try clicking on edit:

17:15:33.933 Uncaught TypeError: defaultEmail is undefined
getDefaultEmail chrome://messenger/content/addressbook/edit/edit.js:313
updateEmailHeading chrome://messenger/content/addressbook/edit/edit.js:294
updateView chrome://messenger/content/addressbook/edit/edit.js:172
set vCardProperties chrome://messenger/content/addressbook/edit/edit.js:110
editCurrentContact chrome://messenger/content/addressbook/aboutAddressBook.js:2858
_onClick chrome://messenger/content/addressbook/aboutAddressBook.js:3180
handleEvent chrome://messenger/content/addressbook/aboutAddressBook.js:2313
edit.js:313:5
getDefaultEmail chrome://messenger/content/addressbook/edit/edit.js:313
updateEmailHeading chrome://messenger/content/addressbook/edit/edit.js:294
updateView chrome://messenger/content/addressbook/edit/edit.js:172
set vCardProperties chrome://messenger/content/addressbook/edit/edit.js:110
editCurrentContact chrome://messenger/content/addressbook/aboutAddressBook.js:2858
_onClick chrome://messenger/content/addressbook/aboutAddressBook.js:3180
handleEvent chrome://messenger/content/addressbook/aboutAddressBook.js:2313

The exported vCard from Thunderbird :

BEGIN:VCARD
VERSION:3.0
UID:XXX-XXXXXXXX-XX-XXXXXXXX
CLASS:PUBLIC
PROFILE:VCARD
PRODID:-//Inverse inc./SOGo 5.7.0//EN
N:;Name
FN:Name
X-MOZILLA-HTML:FALSE
EMAIL;TYPE=work:xyz@example.de
EMAIL;TYPE=home:abc@example.org
END:VCARD

Expected results:

The contact should be editable - I think the best option is to use the first E-Mail address as preferred when no option is configured as a fallback - as PREF=1 is an optional field:
rfc6350 section-6.4.2: Special notes: The property can include tye "PREF" parameter to indicate a preferred-use email address when more than one is specified.

Blocks: tb102found
Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1777214
You need to log in before you can comment on or make changes to this bug.