Closed Bug 1785179 Opened 2 months ago Closed 1 month ago

Thunderbird 102 periodically hangs when showing Move To > Recent menu

Categories

(Thunderbird :: Mail Window Front End, defect)

Thunderbird 102
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: garret, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: perf)

Steps to reproduce:

After I first open Thunderbird for the day, I right-click on a message in the list and select Move To > Recent from the context menu to get a list of recent destination folders.

Actual results:

Thunderbird will hang for 5–10 seconds before showing the list.

This never happened on Thunderbird 9X, or with any earlier version that I can remember, even though I've historically had a very long list of recent-move-destination folders.

Expected results:

Thunderbird should have immediately shown me the list without pausing for up to 10 seconds.

This is irritating to have Thunderbird just freeze up on me at least once a day, as Move To > Recent is one of the features I use most often.

This is on Windows 10. (The new bug form didn't seem to provide an option for me to indicate that.)

Flags: needinfo?(garret)
Keywords: perf

I think we should probably keep all related reports in the original bug - if this is still happening on versions which we want to fix, we must reopen bug 1773401.

Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Component: Untriaged → Mail Window Front End
Resolution: --- → DUPLICATE
Duplicate of bug: 1773401

What is your precise version of Thunderbird?

102.1.2 (64-bit)

Flags: needinfo?(garret)

This is not just "slowness". The application actually stops responding for a while.

This is a brand new installation on a clean Windows 10 installation, so It's not like there is XX years of cached information or something causing Thunderbird to have a hiccup.

No, this would not be a duplicate of bug 1773401. Yes, the same symptoms, but the people who reported issues in that time frame have their problem resolved.

Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Summary: Thunderbird 102 periodically hangs which showing Move To > Recent menu → Thunderbird 102 periodically hangs when showing Move To > Recent menu
Blocks: tb102found

I wanted to report that Thunderbird just updated to v102.2.0, and now it doesn't seem to freeze temporarily when using the Move To > Recent menu. Thank you; that was getting really annoying.

(I'm afraid to even wonder what Thunderbird was doing that would freeze the program when I merely opened a menu. 😬)

Status: REOPENED → RESOLVED
Closed: 2 months ago1 month ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.