Closed Bug 1786107 Opened 3 months ago Closed 3 months ago

Dutch (nl) localisation of TB 102.2 (build2) is broken

Categories

(Thunderbird :: General, defect)

defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: b1, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/104.0.5112.81 Safari/537.36 Edg/104.0.1293.54

Steps to reproduce:

We downloaded
http://ftp.mozilla.org/pub/thunderbird/candidates/102.2.0-candidates/build2/win64/nl/

According to https://pontoon.mozilla.org/projects/thunderbird/, Dutch is 100% complete and it has been fully localised in the past. However, there are now heaps of English strings:
Spaces toolbar icon: Mail, Address Book, etc.
Edit: Cut, Copy, Paste
Tools (Extra): Settings
Help: Trouble Shoot Mode, More Trouble Shooting information.

All those strings are missing from the respective language pack as well.

For example, the spaces icon strings are:
spaces-toolbar-button-mail2 messenger.xhtml
spaces-toolbar-button-address-book2 messenger.xhtml
spaces-toolbar-button-calendar2 messenger.xhtml
spaces-toolbar-button-tasks2 messenger.xhtml
spaces-toolbar-button-chat2 messenger.xhtml

And they are present in the localisation:
https://searchfox.org/l10n/search?q=spaces-toolbar-button&path=nl%2Fmail%2Fmessenger%2Fmessenger.ftl&case=false&regexp=false

Flags: needinfo?(rob)

Pinning changed here:
https://hg.mozilla.org/releases/comm-esr102/rev/ebec14a23058b95d5b8611b50062fa4985a16d41#l1.547

-        "revision": "524e51fc71aa2c928213ff4cb4597e9098c46d20"
+        "revision": "e73df1c882c13778a0a1a9521877ff31310b98ec"

but no breaking changes in the range: https://hg.mozilla.org/l10n-central/nl/pushloghtml

This is not a bug for the Dutch localization.

Assignee: dutch.nl → nobody
Component: nl / Dutch → General
Product: Mozilla Localizations → Thunderbird

(In reply to Francesco Lodolo [:flod] from comment #2)

This is not a bug for the Dutch localization.

Seems to be a build issue.

(In reply to Magnus Melin [:mkmelin] from comment #3)

xref bug 1775273

Not really, see comment #0. Things like
Edit: Cut, Copy, Paste
Tools (Extra): Settings
Help: Trouble Shoot Mode, More Trouble Shooting information.
are also affected. It's possible that not only "nl" is broken. We've checked a few others "es-AR", "ja", "fr", "de" and they were OK (with "de" missing the new strings from bug 1775273).

Diff between working 102.1.1 and non-working 102.2. Should this
Only in D:\Desktop\nl\102.2/localization/nl/toolkit/global: tabprompts.ftl
be the issue? Xref bug 1779330 and bug 1586984.

All those strings are missing from the respective language pack as well.

That is incorrect. They are present as the comparison shows.

According to l10n-changesets.json, nl is using https://hg.mozilla.org/l10n-central/nl/rev/e73df1c882c13778a0a1a9521877ff31310b98ec

Which is missing mailWidgets.ftl.

Apparently you uplifted a patch to esr102, adding a brand new file loaded in the main bundle for messenger.xhtml.
https://bugzilla.mozilla.org/show_bug.cgi?id=574986

So, it inevitably falls back entirely to English, since bug 1779330 is not in esr102. There is even a comment there saying that this exact problem will happen…

P.S. With my localizer hat on: independently from this issue (the whole thing falling back to English), landing a patch and uplifting it 2 weeks after is a very poor experience for users and for volunteers. Their work will look sloppy, and it's not their fault.

(In reply to Francesco Lodolo [:flod] from comment #6)

According to l10n-changesets.json, nl is using https://hg.mozilla.org/l10n-central/nl/rev/e73df1c882c13778a0a1a9521877ff31310b98ec
Which is missing mailWidgets.ftl.

Right, so the pinning needs to be changed to
https://hg.mozilla.org/l10n-central/nl/rev/071fa7bd2a53a0787a6ed703d595f09e6eaf64e0
which contains the file. One push after what is used now, see https://hg.mozilla.org/l10n-central/nl/pushloghtml.

There is also bug 1766604 comment #9 causing more "sloppiness".

https://searchfox.org/l10n/search?q=mailWidgets.ftl&path=&case=false&regexp=false
The majority of locales don't have mailWidgets.ftl yet.

It was a mistake to uplift bug 574986 without a way to handle the en-US fallback caused by mailWidgets.ftl not being present. It will be backed out from comm-esr102.

The path forward is via bug 1779330. That will be on comm-beta after today's merge and version bump. Verification of generated langpack XPIs as well as the localized builds will need to be completed prior to c-esr102 uplift.

Flags: needinfo?(rob)

Close this bug now?

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.