File bookmark(s)... deletes a bookmark folder if folder is in Personal Toolbar

RESOLVED DUPLICATE of bug 176131

Status

--
critical
RESOLVED DUPLICATE of bug 176131
16 years ago
14 years ago

People

(Reporter: ossi, Assigned: bugs)

Tracking

({dataloss})

Trunk
x86
All
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

"File bookmark(s)..." deletes a bookmark folder if folder is in Personal Toolbar
and folder has a subfolder where bookmark should be saved.

This is working fine if "File bookmark(s)..." is selected from "Bookmarks" menu.

Reproducible: Always

Steps to Reproduce:
1. Go to page to be bookmarked
2. Right click the folder in Personal Toolbar and select "File bookmark(s)..."
3. Select a subfolder from previous folder and click ok

Actual Results:  
The folder in Personal Toolbar is deleted (and all it's subfolder and bookmarks).
 

Expected Results:  
It should add the bookmark to specified (sub)folder.

In same case if the bookmark is to be added to that "main" folder in Personal
Toolbar it won't be added. Nothing seems to happen?
This is also working fine if "File bookmark(s)..." is selected from "Bookmarks"
menu.
Confirmed on linux, mozilla trunk cvs 2002-11-05. Somewhat similar stuff: bug
92380 bug 91438
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: dataloss

Comment 2

16 years ago
One of my friends just confirmed this on XP using 1.2.1
OS: Linux → All

Comment 3

16 years ago
By the definitions on <http://bugzilla.mozilla.org/bug_status.html#severity> and
<http://bugzilla.mozilla.org/enter_bug.cgi?format=guided>, crashing and dataloss
bugs are of critical or possibly higher severity.  Only changing open bugs to
minimize unnecessary spam.  Keywords to trigger this would be crash, topcrash,
topcrash+, zt4newcrash, dataloss.
Severity: normal → critical

Updated

16 years ago
Blocks: 123929

Comment 4

16 years ago
Confirming with Mozilla 1.3 on WinXP.

Comment 5

16 years ago
*** Bug 184978 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago

*** This bug has been marked as a duplicate of 176131 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
No longer blocks: 123929
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.