Last Comment Bug 179056 - "Check for new message every" stops after hibernate
: "Check for new message every" stops after hibernate
Status: RESOLVED FIXED
: fixed1.8.0.4, fixed1.8.1
Product: MailNews Core
Classification: Components
Component: Backend (show other bugs)
: Trunk
: x86 Windows 2000
: -- normal with 3 votes (vote)
: ---
Assigned To: Masatoshi Kimura [:emk]
:
Mentors:
: 245471 271183 275727 282014 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-08 04:06 PST by Claudio Cicali
Modified: 2008-07-31 01:21 PDT (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
implementing wake/sleep notification (5.12 KB, patch)
2006-02-20 05:11 PST, Masatoshi Kimura [:emk]
roc: superreview+
Details | Diff | Splinter Review
widget: Win32 part (4.23 KB, patch)
2006-02-20 05:11 PST, Masatoshi Kimura [:emk]
emaijala+moz: review+
Details | Diff | Splinter Review
XPCOM part (907 bytes, patch)
2006-02-20 05:13 PST, Masatoshi Kimura [:emk]
sfraser_bugs: review+
Details | Diff | Splinter Review
branch patch (5.12 KB, patch)
2006-02-24 05:49 PST, Masatoshi Kimura [:emk]
emaijala+moz: approval‑branch‑1.8.1+
Details | Diff | Splinter Review
branch patch (5.12 KB, patch)
2006-02-25 04:49 PST, Masatoshi Kimura [:emk]
VYV03354: approval‑branch‑1.8.1+
Details | Diff | Splinter Review
fixing mingw bustage (trunk) (860 bytes, patch)
2006-02-25 08:18 PST, Masatoshi Kimura [:emk]
roc: review+
roc: superreview+
Details | Diff | Splinter Review
fixing mingw bustage (1.8 branch) (819 bytes, patch)
2006-02-25 08:19 PST, Masatoshi Kimura [:emk]
roc: approval‑branch‑1.8.1+
Details | Diff | Splinter Review
fixing mingw bustage (trunk, updated) (852 bytes, patch)
2006-02-27 05:52 PST, Masatoshi Kimura [:emk]
VYV03354: review+
VYV03354: superreview+
Details | Diff | Splinter Review
fixing mingw bustage (1.8 branch, updated) (811 bytes, patch)
2006-02-27 05:52 PST, Masatoshi Kimura [:emk]
VYV03354: approval‑branch‑1.8.1+
Details | Diff | Splinter Review
1.8.0 branch patch (5.50 KB, patch)
2006-04-22 12:35 PDT, Masatoshi Kimura [:emk]
dveditz: approval1.8.0.4+
Details | Diff | Splinter Review

Description Claudio Cicali 2002-11-08 04:06:28 PST
When resuming Windows from hibernate (on a laptop, HP Omnibook xe4500) Mozilla
Mail does not check my IMAP account every 2 minutes as it does normally. I need
to manually check mail one time and then the feature began to work properly.
Using Mozilla 1.2b/en on a Windows 2000 SP3
Comment 1 s.marshall 2003-11-14 02:08:01 PST
This still happens on Thunderbird 0.3, Win2k SP4.
Comment 2 vakos 2004-03-24 00:20:49 PST
Hi
Exactly the same on
winxp sp1 + hotfixes
mozilla 1.6
this is really annoying problem :(
Comment 3 Greger Cronquist 2004-03-29 22:41:00 PST
I also have this problem on a win2k with Mozilla 1.7b using POP servers.
Comment 4 Greger Cronquist 2004-10-19 06:36:27 PDT
I can confirm this with

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2) Gecko/20040803

on a Win2K laptop (2 POP servers).
Comment 5 Moritz Strübe 2005-01-13 00:26:47 PST
bug 275727, bug 271183 and bug 179056 are dups. Can someone dup them and confirm
one?
Comment 6 Mike Cowperthwaite 2005-02-10 08:54:24 PST
*** Bug 271183 has been marked as a duplicate of this bug. ***
Comment 7 parish 2005-02-10 09:23:09 PST
This also affects Firefox and, I expect the browser component in Mozilla, in
that Live Bookmarks are no longer refreshed every X seconds - as defined by
browser.bookmarks.livemark_refresh_seconds - after hibernate/standby. Perhaps
the Component field of this bug should be set to something more general?

Comment 8 Moritz Strübe 2005-02-12 01:31:16 PST
Can someone please dup bug 245471.
Thanks
Comment 9 Moritz Strübe 2005-02-12 01:55:36 PST
Did some digging in lxr and filed two bugs:
bug 282013 is slightly related.
This bug should depend on bug 282014.
Comment 10 Dean Tessman 2005-02-22 21:23:38 PST
*** Bug 245471 has been marked as a duplicate of this bug. ***
Comment 11 Adam Guthrie 2005-08-20 10:54:45 PDT
*** Bug 275727 has been marked as a duplicate of this bug. ***
Comment 12 David Whyte 2005-10-21 08:37:27 PDT
This behaviour is not only caused by hibernation, but by putting the PC to sleep
too.

Behaviour is still present in version 1.5 Beta 1 (20050908).  It is very
annoying for RSS feeds!
Comment 13 Mike Cowperthwaite 2005-10-21 10:01:10 PDT
(In reply to comment #12)
> This behaviour is not only caused by hibernation, but by putting the PC to
> sleep too.

I don't see that with any version of TB, 1.0 or 1.5 or 1.6, under Windows 2000.
Bug 179056 is about that situation.  This bug is for hibernate only.
Comment 14 Jon Baumgartner 2005-10-21 10:20:58 PDT
Um, this is bug 179056. And I can confirm it happens with sleep as well on XP.
Comment 15 Mike Cowperthwaite 2005-10-21 12:46:34 PDT
(In reply to comment #14)
> Um, this is bug 179056.

Duh, so it is.  It was bug 275727 that was originally opened for both hibernate 
and standby.
Comment 16 Jon Baumgartner 2005-11-10 06:55:36 PST
Bug 275727 was marked as a dupe of this one, so shouldn't sleep/standby issues be discussed here?
Comment 17 R. H. Allen 2005-12-04 07:25:38 PST
I can confirm that this bug is still present in Thunderbird 1.5 RC1. I have a few additional observations that I haven't seen discussed elsewhere -- perhaps somebody will find something useful in them:

* In my experience, hibernate *usually* produces this problem, but not always. There seems to be a correlation between how long the computer hibernates and whether or not the problem occurs. Generally, if I hibernate for only an hour or two, Thunderbird works fine; however, if I hibernate overnight, Thunderbird won't check mail on schedule anymore.

* After returning from hibernate, if I let Thunderbird sit long enough it will sometimes begin checking messages on schedule again. "Long enough" is occasionally only 20 minutes or so, but is usually several hours. I should note that I don't usually let Thunderbird sit long enough to "fix" itself -- if it doesn't work immediately I usually restart it pretty quickly -- so my experience with this is limited.

* I also use Sunbird 0.2 and I have found that after returning from hibernate, if Thunderbird won't check email, Sunbird's alarm function also won't work. The two go hand-in-hand. Perhaps the bug lies in a common piece of code?
Comment 18 Moritz Strübe 2005-12-04 07:35:34 PST
Well, it is a bit deeper. See my Comment #9; This Bug is dependent on Bug 282014. Unfortunately I don not have the right to set it dependent. Bug 282014 ist XPCOM - so _all_ Products have this Problem. You can eaven reproduce it with FF if you use some extension, which needs a timer.
As you noticed right it got better, though.
Comment 19 parish 2005-12-04 09:21:25 PST
(In reply to comment #18)
> Bug 282014
> ist XPCOM - so _all_ Products have this Problem. You can eaven reproduce it
> with FF if you use some extension, which needs a timer.

Yes, Live Bookmarks (RSS feeds) stop updating in FF (and TB too I would think, but I don't use TB for RSS) after hibernate.

Comment 20 Masatoshi Kimura [:emk] 2006-02-20 05:11:11 PST
Created attachment 212472 [details] [diff] [review]
implementing wake/sleep notification

At present, wake/sleep notification is only implemented on Mac. They are not notified at all on other platforms.
This patch implements them on Windows.
A Japanese tester said this fixed the problem.
Comment 21 Masatoshi Kimura [:emk] 2006-02-20 05:11:53 PST
Created attachment 212473 [details] [diff] [review]
widget: Win32 part
Comment 22 Masatoshi Kimura [:emk] 2006-02-20 05:13:08 PST
Created attachment 212474 [details] [diff] [review]
XPCOM part

Requesting review to Simon who wrote and reviewed a patch for bug 197863.
Comment 23 David :Bienvenu 2006-02-21 07:36:37 PST
Comment on attachment 212472 [details] [diff] [review]
implementing wake/sleep notification

I think we'll want this for 1.8.1 (and possibly but less likely, 1.8.0.2, depending on schedule)
Comment 24 Brian Ryner (not reading) 2006-02-21 12:32:29 PST
Comment on attachment 212472 [details] [diff] [review]
implementing wake/sleep notification

Hm, is the message really dispatched to each window?  That's unfortunate.  I'm a little worried that we could have 0, or more than 1, invisible windows in some cases.  roc would know better than me, can you ask him for review?
Comment 25 Robert O'Callahan (:roc) (email my personal email if necessary) 2006-02-21 13:22:44 PST
I didn't know, but I checked the code and it seems pretty clear there's always exactly one hidden window.
Comment 26 Masayuki Nakano [:masayuki] (Mozilla Japan) (Offline: 9/19, 9/22-9/25, 9/28)) 2006-02-23 09:03:15 PST
checked-in.
Comment 27 Masatoshi Kimura [:emk] 2006-02-23 09:49:05 PST
*** Bug 282014 has been marked as a duplicate of this bug. ***
Comment 28 Masatoshi Kimura [:emk] 2006-02-24 05:49:00 PST
Created attachment 213042 [details] [diff] [review]
branch patch

Bienvenu:
AFAIK, approval‑branch‑1.8.1 flag needs a requestee.
Asking Ere for approval because most of this patch belong to Win32: widget.
Comment 29 Ere Maijala (slow) 2006-02-24 12:44:57 PST
Comment on attachment 213042 [details] [diff] [review]
branch patch

Sorry, I can't grant approval as I'm not a driver.
Comment 30 David :Bienvenu 2006-02-24 12:46:03 PST
for the 1.8.1 branch, you just have to be a module owner
Comment 31 Ere Maijala (slow) 2006-02-24 12:47:39 PST
Comment on attachment 213042 [details] [diff] [review]
branch patch

Oh, good to know. Ok then..
Comment 32 Robert O'Callahan (:roc) (email my personal email if necessary) 2006-02-24 21:36:09 PST
Comment on attachment 212472 [details] [diff] [review]
implementing wake/sleep notification

ere already approved this
Comment 33 Masayuki Nakano [:masayuki] (Mozilla Japan) (Offline: 9/19, 9/22-9/25, 9/28)) 2006-02-25 01:35:08 PST
Kimura-san:

This patch cannot apply to 1.8 branch.

> patching file widget/src/windows/nsWindow.cpp
> Hunk #1 FAILED at 66.
> Hunk #2 succeeded at 4167 (offset 182 lines).
> Hunk #3 succeeded at 4297 (offset 182 lines).
> 1 out of 3 hunks FAILED -- saving rejects to file widget/src/windows/nsWindow.cpp.rej
> (Stripping trailing CRs from patch.)
> patching file widget/src/windows/nsWindow.h
> Hunk #1 FAILED at 262.
> 1 out of 1 hunk FAILED -- saving rejects to file widget/src/windows/nsWindow.h.rej
> (Stripping trailing CRs from patch.)
> patching file xpcom/threads/TimerThread.cpp
Comment 34 Masatoshi Kimura [:emk] 2006-02-25 04:49:07 PST
Created attachment 213172 [details] [diff] [review]
branch patch

Oops, that was the same as trunk patch.
Here is a correct one. I've confirmed this is not rejected.
Carrying over branch approval (no actual code change).
Comment 35 Masayuki Nakano [:masayuki] (Mozilla Japan) (Offline: 9/19, 9/22-9/25, 9/28)) 2006-02-25 04:55:29 PST
checked-in to 1.8 branch.
Comment 36 neil@parkwaycc.co.uk 2006-02-25 06:38:11 PST
My MinGW headers don't have these PBT_ constants, do I need to update?
Comment 37 Masatoshi Kimura [:emk] 2006-02-25 08:18:12 PST
Created attachment 213178 [details] [diff] [review]
fixing mingw bustage (trunk)
Comment 38 Masatoshi Kimura [:emk] 2006-02-25 08:19:18 PST
Created attachment 213179 [details] [diff] [review]
fixing mingw bustage (1.8 branch)
Comment 39 Robert O'Callahan (:roc) (email my personal email if necessary) 2006-02-26 14:16:22 PST
Comment on attachment 213178 [details] [diff] [review]
fixing mingw bustage (trunk)

+#else

unnecessary.
Comment 40 Robert O'Callahan (:roc) (email my personal email if necessary) 2006-02-26 14:16:57 PST
Comment on attachment 213179 [details] [diff] [review]
fixing mingw bustage (1.8 branch)

but remove the #else.
Comment 41 Masatoshi Kimura [:emk] 2006-02-27 05:52:13 PST
Created attachment 213313 [details] [diff] [review]
fixing mingw bustage (trunk, updated)
Comment 42 Masatoshi Kimura [:emk] 2006-02-27 05:52:55 PST
Created attachment 213314 [details] [diff] [review]
fixing mingw bustage (1.8 branch, updated)
Comment 43 Masayuki Nakano [:masayuki] (Mozilla Japan) (Offline: 9/19, 9/22-9/25, 9/28)) 2006-02-27 07:11:48 PST
checked-in to trunk and 1.8 branch.(fixed mingw bustage)
Comment 44 Cris 2006-03-16 16:59:22 PST
File :

ftp://ftp.mozilla.org/.1/mozilla/pub/mozilla.org/firefox/nightly/latest-mozilla1.8.0/firefox-1.5.0.2.en-US.win32.zip  
6721 KB  	16/03/2006  	17.26.00

has this patch?

Where can I find first realeses with this patch?
Comment 45 David :Bienvenu 2006-03-16 17:13:01 PST
ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-mozilla1.8

however, that's a pre-alpha build. I think it's reasonably stable but hasn't had much testing.
Comment 46 Cris 2006-03-27 00:00:57 PST
Last firefox 1.5.0.2 still has the problems to take forever to restore from hibernation and reach 100% CPU.

I found interesting the description of bug 325384. It is about SeaMonkey but it
is probably related with the long time to recover from standby.
Comment 47 Masatoshi Kimura [:emk] 2006-04-22 12:35:00 PDT
Created attachment 219440 [details] [diff] [review]
1.8.0 branch patch

Plaease consider landing this on 1.8.0 branch.
This will fix some of (but not all) CPU 100% freeze after resore in bug 265172.
And this is baked enough long on trunk and 1.8 branch.
Comment 48 Daniel Veditz [:dveditz] 2006-04-24 16:38:20 PDT
Comment on attachment 219440 [details] [diff] [review]
1.8.0 branch patch

approved for 1.8.0 branch, a=dveditz for drivers.

Please land soon!
Comment 49 Cris 2006-04-25 01:00:00 PDT
Sorry, I am not familiar with Mozilla versions.
What does "approved for 1.8.0 branch, a=dveditz for drivers." mean?
Will I see this patch in the next 1.5.0.3 version?
When will it be released?
Comment 50 Masayuki Nakano [:masayuki] (Mozilla Japan) (Offline: 9/19, 9/22-9/25, 9/28)) 2006-04-25 02:34:46 PDT
checked-in to 1.8.0 branch. thanks.

Note You need to log in before you can comment on or make changes to this bug.