Status

()

RESOLVED FIXED
16 years ago
10 years ago

People

(Reporter: akkzilla, Assigned: blizzard)

Tracking

({fixed1.4.1})

Trunk
x86
Linux
fixed1.4.1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
I've been helping Aaron test bug 176602, but it turns out nsSound::Play doesn't
do anything on Redhat 7.3 (haven't tried other distros yet).  Sound on this box
works fine: I use sound in lots of other apps.

Chris, if you're the wrong person, sorry, please reassign.  Your name seemed to
be on other linux sound bugs so I took a guess.

I am getting to nsSound::OnStreamComplete, and if I un-ifdef the printf I see
f: 1 | c: 1 | sps: -18 | abps: -36 | ba: 2 | bps: 16 | rate: -36

The write at the end writes 1444 bytes (exactly the length of notfound.wav) to
the fd, returning 1444.  But no sound is heard, whether or not I have esd
running.  The wav file plays fine outside of mozilla using play (from
sox-12.17.3-4), or if I start esd and run esdplay on the wav file.

Other testing reports (in bug 176602) say that it doesn't work on stock Redhat 8
either, but it does work after installing the upgrade "arts-2.2.2-1.i386.rpm". 
No reports yet from any non-Redhat systems; I'll try pulling a debian tree one
of these days.

This is with gtk1.  gtk2 doesn't currently build for me, probably a configure
issue (it's not finding my gtk2 include files) though I have re-run configure
after setting MOZ_WIDGET_TOOLKIT=gtk2.  (Is there any way yet to have both gtk
and gtk2 widget libraries build automatically in the same tree?)

Comment 1

16 years ago
Akkana, put those 2 options into your .mozconfig file, you can get a gtk2 build
easily :)

ac_add_options --enable-default-toolkit=gtk2
ac_add_options --disable-gtktest

my report for RedHat 8.0 is wrong, it just works for gtk2 build. The
arts-2.2.2-1.i386.rpm was installed for fixing the segment fault issue of xmms.
*** Bug 179817 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
See my patch for bug 177280.
GET_DWORD macro was incorrect and rate was not being set corrected.
(Assignee)

Updated

16 years ago
Blocks: 92033

Comment 4

16 years ago
Created attachment 124035 [details] [diff] [review]
Patch for nsSound.cpp v1

Fixes problem with playback of some wav files.	Implements playSystemSound as
well.

Updated

16 years ago
Attachment #124035 - Flags: superreview?(blizzard)
Attachment #124035 - Flags: review?(pavlov)

Comment 5

16 years ago
*** Bug 104174 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Blocks: 207436

Comment 6

16 years ago
pavlov and blizzard, can I get a r/sr?

Updated

16 years ago
Attachment #124035 - Flags: review?(pavlov) → review+

Comment 7

16 years ago
blizzard, can I get a sr?

Comment 8

16 years ago
Comment on attachment 124035 [details] [diff] [review]
Patch for nsSound.cpp v1

Can we get this in for 1.4?
Attachment #124035 - Flags: approval1.4?

Updated

16 years ago
Attachment #124035 - Flags: superreview?(blizzard) → superreview?(bryner)
(Assignee)

Comment 9

16 years ago
Comment on attachment 124035 [details] [diff] [review]
Patch for nsSound.cpp v1

sr=blizzard
Attachment #124035 - Flags: superreview?(bryner) → superreview+
I checked the patch here in, hope you don't mind:
Checking in widget/src/gtk/nsSound.cpp;
/cvsroot/mozilla/widget/src/gtk/nsSound.cpp,v  <--  nsSound.cpp
new revision: 1.35; previous revision: 1.34
done

leaving open to maybe get it on 1.4 branch.

Does Gtk2 need a similar patch?
(Assignee)

Comment 11

16 years ago
I imagine it does.

Comment 12

16 years ago
Created attachment 125245 [details] [diff] [review]
Patch for GTK2 nsSound.cpp

Updated

16 years ago
Attachment #125245 - Flags: superreview?(blizzard)
Attachment #125245 - Flags: review?(pavlov)

Comment 13

16 years ago
Created attachment 125249 [details] [diff] [review]
Patch for GTK2 nsSound v1.1

Previous patch had a syntax error.  I don't have a gtk2 build environment.
Attachment #125245 - Attachment is obsolete: true

Updated

16 years ago
Attachment #125249 - Flags: superreview?(blizzard)
Attachment #125249 - Flags: review?(pavlov)
The Gtk2 patch here works - I created an identical patch and tested it.

Updated

16 years ago
Attachment #125245 - Flags: superreview?(blizzard)
Attachment #125245 - Flags: review?(pavlov)

Updated

16 years ago
Flags: blocking1.4?
(Assignee)

Comment 15

16 years ago
Comment on attachment 125249 [details] [diff] [review]
Patch for GTK2 nsSound v1.1

sr=blizzard and I checked it in.  I changed a few style-related things, but
it's the same patch.
Attachment #125249 - Flags: superreview?(blizzard)
Attachment #125249 - Flags: superreview+
Attachment #125249 - Flags: review?(pavlov)

Comment 16

15 years ago
Comment on attachment 124035 [details] [diff] [review]
Patch for nsSound.cpp v1

moving approval request forward.
Attachment #124035 - Flags: approval1.4? → approval1.4.x?

Comment 17

15 years ago
Comment on attachment 124035 [details] [diff] [review]
Patch for nsSound.cpp v1

Can we get this in for 1.4.1?

Comment 18

15 years ago
mozilla1.4 shipped. unsetting blocking1.4 request.
Flags: blocking1.4?

Comment 19

15 years ago
blizzard, cbiesinger, can you guys get these patches into the 1.4 branch? We're
short on time. 

Comment 20

15 years ago
Comment on attachment 124035 [details] [diff] [review]
Patch for nsSound.cpp v1

a=asa (on behalf of drivers) for checkin to the 1.4 branch
Attachment #124035 - Flags: approval1.4.x? → approval1.4.x+
OK, both gtk1 and gtk2 patch checked into the 1.4 branch:

Checking in gtk/nsSound.cpp;
/cvsroot/mozilla/widget/src/gtk/nsSound.cpp,v  <--  nsSound.cpp
new revision: 1.34.20.1; previous revision: 1.34
done
Checking in gtk2/nsSound.cpp;
/cvsroot/mozilla/widget/src/gtk2/nsSound.cpp,v  <--  nsSound.cpp
new revision: 1.5.4.1; previous revision: 1.5
done

This means this bug is fixed, I would say. marking so.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Keywords: fixed1.4.1
Resolution: --- → FIXED

Updated

15 years ago
Blocks: 224532
You need to log in before you can comment on or make changes to this bug.