Closed Bug 1791539 Opened 2 months ago Closed 2 months ago

[wayland] Bookmark toolbar folders located on the left side of the window have a misaligned drop indicator during drag operations

Categories

(Core :: Widget: Gtk, defect, P3)

Firefox 107
defect

Tracking

()

VERIFIED FIXED
107 Branch
Tracking Status
firefox107 --- verified

People

(Reporter: ke5trel, Assigned: stransky)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files)

STR:

  1. Start with MOZ_ENABLE_WAYLAND=1 on Ubuntu 22.04.
  2. Create a bookmark toolbar folder with a long list of items.
  3. Position the folder on the left-most side of the toolbar.
  4. Open the folder and drag bookmarks around, moving the cursor over the lower-right region of the popup.

The drop indicator/location is vertically offset above the cursor by four items when the cursor is on the right side of the popup and sufficiently low enough. The width of the affected region shrinks for popups further from the left side of the window.

Blocks: linuxdad

Yes, I can confirm that.

Priority: -- → P3
No longer blocks: wayland-popup

Due to https://gitlab.gnome.org/GNOME/gtk/-/issues/4437 / Bug 1710344 we need to add popup window position to D&D coordinates provided by Gtk.
In this patch always use GdkWindow derived from mShell which is attached to parent window.
Don't use GdkWindow of mContainer which is nested child window and it's positioned at 0,0.

Assignee: nobody → stransky
Status: NEW → ASSIGNED
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/2badfb13cc06
[Wayland] Use mShell Gdk window position for D&D r=emilio
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 107 Branch
Depends on: 1794597
QA Whiteboard: [qa-107b-p2]

I managed to reproduce this issue on a 2022-09-20 Nightly build(Wayland session) on Ubuntu 22 using the STR from the Description. Verified as fixed on Firefox 107.0b3(build ID: 20221020202724) and Nightly 108.0a1(build ID: 20221020215126).

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-107b-p2]
You need to log in before you can comment on or make changes to this bug.