Closed Bug 1792281 Opened 2 months ago Closed 2 months ago

Hang with 400/502 greeting NNTP code

Categories

(MailNews Core :: Networking: NNTP, defect)

Thunderbird 102
defect

Tracking

(thunderbird_esr102 fixed, thunderbird106 affected)

RESOLVED FIXED
107 Branch
Tracking Status
thunderbird_esr102 --- fixed
thunderbird106 --- affected

People

(Reporter: bugzilla, Assigned: rnons)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/16.0 Safari/605.1.15

Steps to reproduce:

When connecting to a news server that responds
400 Permission denied: Not welcome!
as its initial greeting (instead of 200 or 201 code for instance), the cursor shows a spinning wheel and I do not receive any error message in Thunderbird.

Expected results:

I would have expected an error message in a pop-up.
Thunderbird should handle standard response codes that can be received in the greeting banner (200, 201, 400, 502).
Also note that the 400 response code is similarly not correctly handled (no pop-up with an error message) during the NNTP session, for instance receiving it after authentication or any other command.

Component: Untriaged → Networking: NNTP
Product: Thunderbird → MailNews Core
See Also: → 1786203

Confirmed.
Even with a 502 response, the TB does not give any feedback.
The CPP module does.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Regressed by: nntp-js
Keywords: regression
Summary: Hang with 400 greeting NNTP code → Hang with 400/502 greeting NNTP code

Pass urlListener and msgWindow to NntpClient before any real action, to receive stop event and show error dialog.

Assignee: nobody → remotenonsense
Status: NEW → ASSIGNED
Target Milestone: --- → 107 Branch

Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/abcaf011c387
Show error dialog for NNTP server error. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

Comment on attachment 9296436 [details]
Bug 1792281 - Show error dialog for NNTP server error. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): nntp-js
User impact if declined: NNTP errors not displayed
Testing completed (on c-c, etc.): on beta since 107
Risk to taking this patch (and alternatives if risky):should be low

[Triage Comment]
Approved for 102.5.0

Attachment #9296436 - Flags: approval-comm-esr102+
You need to log in before you can comment on or make changes to this bug.