Closed Bug 1786203 Opened 2 months ago Closed 1 month ago

NNTP client becomes stuck when connecting to Public-Inbox servers

Categories

(MailNews Core :: Networking: NNTP, defect)

Thunderbird 102
defect

Tracking

(thunderbird_esr102+ fixed, thunderbird105 fixed)

RESOLVED FIXED
106 Branch
Tracking Status
thunderbird_esr102 + fixed
thunderbird105 --- fixed

People

(Reporter: grawity, Assigned: rnons)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Steps to reproduce:

Thunderbird 102 can no longer connect to NNTP servers running Public-Inbox (such as "nntp.lore.kernel.org" or "inbox.vuxu.org"). When trying to check such a server for new posts, or when trying to open an unread message, the app just forever sits at "Loading Message".

The same servers worked in TB 9x, and after setting the 'mailnews.nntp.jsmodule' option to 'false' (which I assume re-activates the old TB 9x code), such servers start to work again.

Meanwhile, connections to other NNTP servers (e.g. "news.gmane.io") still work correctly even in TB 102.

Steps:

  1. In TB 9x, add "nntp.lore.kernel.org" as an NNTP server, subscribe to a group, make sure TB is able to read messages.
  2. Upgrade to TB 102 and try to check the groups for new messages, or read some unread messages.

Actual results:

The message list is never updated. When trying to read a message, the body is not loaded and the status bar is stuck at "Loading Message" forever.

Packet capture shows that a TCP connection is established and the server sends its greeting, but Thunderbird never sends any commands to the server.

(One difference is that the server greeting uses a 201 status code instead of 200, as these servers are read-only. I wonder if the new code isn't prepared to handle that.)

Component: Untriaged → Networking: NNTP
Product: Thunderbird → MailNews Core

(In reply to Mantas Mikulėnas (grawity) from comment #0)

Thunderbird 102 can no longer connect to NNTP servers running Public-Inbox (such as "nntp.lore.kernel.org" or "inbox.vuxu.org"). When trying to check such a server for new posts, or when trying to open an unread message, the app just forever sits at "Loading Message".

Yes, both servers answer with a 201 response:

mailnews.nntp: Connecting to news://inbox.vuxu.org:119 NntpClient.jsm:102:20
mailnews.nntp: Connected NntpClient.jsm:120:18
mailnews.nntp: S: 201 inbox.vuxu.org ready - post via email

However, TB only likes the 200 response:
https://searchfox.org/comm-central/rev/1de28ff4bff691f753d7b30b2f7d7fcc9dc546a4/mailnews/news/src/NntpClient.jsm#126

And blocks on everything else.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Regressed by: nntp-js
Target Milestone: --- → 102 Branch

JFTR:
https://www.rfc-editor.org/rfc/rfc3977.html#section-5.1
| 5.1. Initial Connection
| 5.1.1. Usage
| Responses [1]
| 200 Service available, posting allowed
| 201 Service available, posting prohibited

Blocks: tb102found
Assignee: nobody → remotenonsense
Status: NEW → ASSIGNED

Update test_NntpChannel to return 201 from Nntpd test server.

Target Milestone: 102 Branch → 106 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/b8e2bfb22041
Support 201 status code in NntpClient.jsm. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED

Comment on attachment 9291034 [details]
Bug 1786203 - Support 201 status code in NntpClient.jsm. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): bug 1707550
User impact if declined: nntp-js doesn't work for servers returning 201 (posting prohibited)
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9291034 - Flags: approval-comm-beta?

Comment on attachment 9291034 [details]
Bug 1786203 - Support 201 status code in NntpClient.jsm. r=mkmelin

[Triage Comment]
Approved for beta

Attachment #9291034 - Flags: approval-comm-beta? → approval-comm-beta+

[Approval Request Comment]
Regression caused by (bug #): bug 1707550
User impact if declined: nntp-js doesn't work for servers returning 201 (posting prohibited)
Testing completed (on c-c, etc.): beta
Risk to taking this patch (and alternatives if risky): low

Attachment #9294079 - Flags: approval-comm-esr102?

Comment on attachment 9294079 [details] [diff] [review]
1786203-esr102.patch

[Triage Comment]
Approved for esr102

Attachment #9294079 - Flags: approval-comm-esr102? → approval-comm-esr102+
Duplicate of this bug: 1790771
See Also: → 1792281
You need to log in before you can comment on or make changes to this bug.