Closed Bug 1793307 Opened 2 months ago Closed 2 months ago

The searchbar popup is missing a border in HCM again

Categories

(Firefox :: Theme, defect)

defect

Tracking

()

VERIFIED FIXED
107 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox105 --- wontfix
firefox106 --- verified
firefox107 --- verified

People

(Reporter: itiel_yn8, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Bug 1782858 regressed a part of bug 1770210, basically --menu-border-color doesn't exist anymore.
Replacing it with --arrowpanel-border-color here:
https://searchfox.org/mozilla-central/rev/462f51927aaeb97447dd2a9f347ca42b1e6f9fa3/browser/themes/shared/searchbar.css#178
should fix it.

(Also I think the @media here can go away, not sure why I thought it was needed back in the day (or maybe it's not needed anymore -- not sure):
https://searchfox.org/mozilla-central/rev/462f51927aaeb97447dd2a9f347ca42b1e6f9fa3/browser/themes/shared/urlbarView.css#870 )

Set release status flags based on info from the regressing bug 1782858

:emilio, since you are the author of the regressor, bug 1782858, could you take a look? Also, could you set the severity field?

For more information, please visit auto_nag documentation.

Nice catch!

Flags: needinfo?(emilio)
Assignee: nobody → emilio
Status: NEW → ASSIGNED
Component: Widget: Win32 → Theme
Product: Core → Firefox
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/72025dbe3f1c
Fix search panel border color on win10. r=Itiel,desktop-theme-reviewers
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 107 Branch

The patch landed in nightly and beta is affected.
:emilio, is this bug important enough to require an uplift?

  • If yes, please nominate the patch for beta approval.
  • If no, please set status-firefox106 to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(emilio)

Comment on attachment 9296890 [details]
Bug 1793307 - Fix search panel border color on win10. r=Itiel

Beta/Release Uplift Approval Request

  • User impact if declined: Comment 0
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: comment 0
  • List of other uplifts needed: none
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Trivial one-liner CSS fix.
  • String changes made/needed: none
  • Is Android affected?: No
Flags: needinfo?(emilio)
Attachment #9296890 - Flags: approval-mozilla-beta?

Comment on attachment 9296890 [details]
Bug 1793307 - Fix search panel border color on win10. r=Itiel

Approved for 106.0b8, thanks.

Attachment #9296890 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

I've reproduced this issue on Win 10, using an affected Nightly build 107.0a1 (2022-10-01).

The issue is verified as fixed on the latest builds, Beta 106.0b8 and Nightly 107.0a1 (20221005094233).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.