Closed Bug 1798172 Opened 28 days ago Closed 24 days ago

"Copy to <folder> again" menu item not present after copying message to folder with Cyrillic or Japanese name on Gmail

Categories

(Thunderbird :: General, defect)

Thunderbird 102
defect

Tracking

(thunderbird_esr102+ affected, thunderbird107 affected)

RESOLVED FIXED
108 Branch
Tracking Status
thunderbird_esr102 + affected
thunderbird107 --- affected

People

(Reporter: b5, Assigned: mkmelin)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Safari/537.36

Steps to reproduce:

"Copy to <folder> again" menu item not present after copying message to folder with Cyrillic or Japanese name on Gmail.

It works for other non-ASCII folders, like ones with German Umlaut, e.g. Földer.

Already not working in TB 91 (and likely earlier versions).

Works on Gmail with mail.server.default.allow_utf8_accept set to false. The issue is here:
https://searchfox.org/comm-central/rev/396b593b9d21320bc94a7f248ceabb90a7a418b3/mail/base/content/mailWindowOverlay.js#778
getCharPref() only handles Latin1, so "Földer" works, but Cyrillic/Japanese doesn't. Should be getStringPref().

Likely also wrong:
https://searchfox.org/comm-central/search?q=folder.*getcharpref&path=.js&case=false&regexp=true
https://searchfox.org/comm-central/search?q=setcharpref.*folder.*uri&path=mail&case=false&regexp=true

Status: UNCONFIRMED → NEW
Component: Networking: IMAP → General
Ever confirmed: true
Product: MailNews Core → Thunderbird

getCharPref doesn't handle unicode, so the code would fail for e.g. folders with Japanese names if the imap server is set to use utf-8 (allow_utf8_accept).

Based on https://github.com/Betterbird/thunderbird-patches/blob/main/102/bugs/1798172-fix-move-to-folder-again-non-latin1.patch

Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Target Milestone: --- → 108 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/4d322994136c
Use getStringPref/setStringPref for folder URI preferences. r=benc

Status: ASSIGNED → RESOLVED
Closed: 24 days ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.