Closed Bug 1801060 Opened 2 months ago Closed 2 months ago

Address bar no longer retains URL highlight after switching tabs

Categories

(Firefox :: Address Bar, defect, P1)

Firefox 109
defect

Tracking

()

VERIFIED FIXED
109 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox107 --- unaffected
firefox108 --- unaffected
firefox109 --- verified
firefox110 --- verified

People

(Reporter: ke5trel, Assigned: enndeakin)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

STR:

  1. Click in the address bar to highlight the entire URL or manually select all.
  2. Switch to a different tab and back again.

Expected:

The URL should still be highlighted for that tab.

Actual:

The address bar is focused but the URL is not highlighted.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=54bf7e90e341b37087d161b71e008a0f0b654375&tochange=ad7fa1c3acafff6e9d6d4d0e1804c1a08f2b8517

Regressed by Bug 1219775.

:enndeakin, since you are the author of the regressor, bug 1219775, could you take a look? Also, could you set the severity field?

For more information, please visit auto_nag documentation.

Flags: needinfo?(enndeakin)
Severity: -- → S3
Priority: -- → P1
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
See Also: → 1796381
Pushed by neil@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f89db5c7a08b
fix selectURL function call so that url is selected properly, r=Gijs
Flags: needinfo?(enndeakin)
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 109 Branch

== Change summary for alert #36190 (as of Fri, 25 Nov 2022 23:18:21 GMT) ==

Improvements:

Ratio Test Platform Options Absolute values (old vs new)
2% tart macosx1015-64-shippable-qr e10s fission stylo webrender-sw 2.53 -> 2.47
2% tart macosx1015-64-shippable-qr e10s fission stylo webrender-sw 2.52 -> 2.46

For up to date results, see: https://treeherder.mozilla.org/perfherder/alerts?id=36190

Flags: qe-verify+

Reproducible on a 2022-11-16 Nightly build on Windows 10.
Verified as fixed on Firefox 109.0b3(build ID: 20221215185833) and Nightly 110.0a1(build ID: 20221216093922) on Windows 10, Ubuntu 22, macOS 12.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.