Closed Bug 1219775 Opened 8 years ago Closed 1 year ago

The urlbar is not focused when a new tab is opened with Ctrl+T while the window is in DOM full screen mode

Categories

(Firefox :: Tabbed Browser, defect)

defect
Points:
2

Tracking

()

VERIFIED FIXED
109 Branch
Tracking Status
firefox45 --- wontfix
firefox109 --- verified

People

(Reporter: sjakthol, Assigned: enndeakin)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fidefe-Quality-Foundation])

Attachments

(2 files)

STR:
1. Go to https://developer.mozilla.org/samples/domref/fullscreen.html
2. Press Enter to enter full screen mode
3. Press Ctrl+T to open a new tab

What happens: The new tab opens but the urlbar is not focused.
What should happen: The urlbar is focused as if it would if you opened a new tab when the window is not in DOM fullscreen mode.

I can reproduce this issue in both Nightly and current release, Fx41, on Ubuntu 14.04.
I have the same problem on Mac, usually when I decide to pause a video to look something up.
OS: Linux → All
Hardware: x86_64 → All
Component: Keyboard Navigation → Tabbed Browser
Priority: -- → P3

Since there are tons of duplications and because this issue is open for 4 years, despite the fact that it probably annoys the hell out of all who use the fullscreen mode and keyboard shortcuts, which is probably not too less of the userbase: Could somebody please increase the importance?

Thanks in advance

I debugged this a little after working on bug 1610200. It looks like the front end takes all the same code paths it does when not in full-screen mode. The difference is that this conditional is false in full-screen mode but true when not in full screen: https://searchfox.org/mozilla-central/source/dom/html/HTMLInputElement.cpp#3039

I stopped debugging at that point, so I don't know why that is.

I tried adding a one-second timeout here, and that fixed it: https://searchfox.org/mozilla-central/rev/a4be2fbe9bd4f405c91cc16e4e3a80400f5a9301/browser/base/content/browser.js#2906 Full-screen mode is exited right above that. So we might be able to listen for the end of the full-screen transition and then do the select after that.

I can't reproduce this on Windows... Comment 0 mentions Linux and I can reproduce it on macOS (like comment 1), so this is Linux and Mac only?

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:73.0) Gecko/20100101 Firefox/73.0

I can reproduce with the STR in comment 0 on Windows 10.

Ah, actually I can too. I think I didn't follow the STR but used the View > Full Screen command instead. So this is all platforms. Thanks.

Hey Steven, with your recent work on full screen, is this something you could pick up?

Flags: needinfo?(smacleod)

(In reply to :Gijs (he/him) from comment #19)

Hey Steven, with your recent work on full screen, is this something you could pick up?

Ya I can probably take a look soonish.

Assignee: nobody → smacleod
Status: NEW → ASSIGNED
Flags: needinfo?(smacleod)

I have the same issue, it bugs the crap out of me. I happens in Windows 10/11 and in Ubuntu Linux, Firefox 94.0 . November 2021.

The bug assignee didn't login in Bugzilla in the last 7 months.
:dao, could you have a look please?
For more information, please visit auto_nag documentation.

Assignee: steven → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(dao+bmo)

Happens on Firefox 97.0.1 on Macos 12.2.1.

Severity: normal → S3

The severity field for this bug is relatively low, S3. However, the bug has 17 duplicates.
:dao, could you consider increasing the bug severity?

For more information, please visit auto_nag documentation.

Flags: needinfo?(dao+bmo)

The last needinfo from me was triggered in error by recent activity on the bug. I'm clearing the needinfo since this is a very old bug and I don't know if it's still relevant.

Flags: needinfo?(dao+bmo)

I'm going to up the severity here based on the fact that this is one of the most duped bugs in Firefox so it should be in the quality foundation pile.

Severity: S3 → S2
Priority: P3 → --
Whiteboard: [fidefe-Quality-Foundation]
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Points: --- → 2
Pushed by neil@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ad7fa1c3acaf
focus the url bar when opening a new tab while in fullscreen mode, r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 109 Branch

Neil, do you think this is safe for uplift, perhaps after verification by QA?

Flags: needinfo?(dao+bmo) → needinfo?(enndeakin)
Regressions: 1801060

Did something change recently before this fix? I'm in full screen most of the time, and opening a new tab would allow me to type in a new url right away (probably until earlier this week?). But even with the change here, urlbar doesn't have focus on a new tab when in fullscreen.

Edit: nevermind, this bug is the regressing bug. Filed bug 1801168

Regressions: 1801168

(In reply to :Gijs (he/him) from comment #36)

Neil, do you think this is safe for uplift, perhaps after verification by QA?

Given the regression, maybe not for now...

Flags: needinfo?(enndeakin)
No longer regressions: 1801456
Flags: qe-verify+

Reproduced the issue with Firefox 108.0a1 (2022-11-10) on Windows 10x64. After using Ctrl +T while in full screen a new tab is opened and the URL bar is not focused.
The issue is verified fixed with Firefox 109.0b3 on Windows 10x64, macOS 10.15 and Ubuntu 20.04. After following the STR from comment 0 the URL bar is focused.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Duplicate of this bug: 1753665
You need to log in before you can comment on or make changes to this bug.