Closed Bug 1801184 Opened 2 years ago Closed 2 years ago

Update GMP fallback downloader for Widevine CDM 4.10.2557.0

Categories

(Core :: Audio/Video: Playback, task, P2)

task

Tracking

()

RESOLVED FIXED
109 Branch
Tracking Status
firefox-esr102 108+ fixed
firefox107 --- wontfix
firefox108 + fixed
firefox109 + fixed

People

(Reporter: aosmond, Assigned: aosmond)

References

Details

Attachments

(2 files)

Once we've tested and are shipping the 4.10.2557.0 CDM via balrog, we should also update the fallback downloader.

Blocks: 1795749
No longer blocks: 1796787

[Tracking Requested - why for this release]:
Widevine rollout is going out to Release today and ESR by the end of the week. We normally update these URLs after we ship to release. Hence we may miss the 109 cutoff for code freeze. Requesting tracking so we make sure to get these changes uplift if we miss the merge.

Absolutely. We should uplift to 108 as well. There isn't a scheduled dot release for that cycle because of the holidays, but we can still land it so the change is there should the need for a dot release arise.

Pushed by aosmond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6427c2fbb249
Update Widevine fallback downloader URLs for 4.10.2557.0. r=media-playback-reviewers,alwu

Looks like we'll have time to uplift this before we build RCs next week if can get Beta & ESR102 nominations soon.

Flags: needinfo?(aosmond)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 109 Branch

Comment on attachment 9303964 [details]
Bug 1801184 - Update Widevine fallback downloader URLs for 4.10.2557.0.

Beta/Release Uplift Approval Request

  • User impact if declined: In rare cases, we may use the fallback to pull the old Widevine plugins which won't work after Dec 6th.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The change has already been tested in nightly/beta/release/ESR through balrog.
  • String changes made/needed:
  • Is Android affected?: Yes
Flags: needinfo?(aosmond)
Attachment #9303964 - Flags: approval-mozilla-beta?

Comment on attachment 9303964 [details]
Bug 1801184 - Update Widevine fallback downloader URLs for 4.10.2557.0.

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: In rare cases, we may use the fallback to pull the old Widevine plugins which won't work after Dec 6th.
  • User impact if declined: DRM videos won't work if we use fallback to get the plugin
  • Fix Landed on Version: 109
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The change has already been tested in nightly/beta/release/ESR through balrog.
Attachment #9303964 - Flags: approval-mozilla-esr102?

Comment on attachment 9303964 [details]
Bug 1801184 - Update Widevine fallback downloader URLs for 4.10.2557.0.

Approved for 108.0rc1

Attachment #9303964 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment on attachment 9303964 [details]
Bug 1801184 - Update Widevine fallback downloader URLs for 4.10.2557.0.

Approved for 102.6esr.

Attachment #9303964 - Flags: approval-mozilla-esr102? → approval-mozilla-esr102+
Blocks: 1822681
See Also: → 1858988
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: