Closed Bug 1801298 Opened 2 years ago Closed 2 years ago

Fix down/up arrow behavior with multiple selectable elements per row

Categories

(Firefox :: Address Bar, defect, P2)

defect
Points:
3

Tracking

()

VERIFIED FIXED
111 Branch
Tracking Status
firefox109 --- wontfix
firefox110 --- wontfix
firefox111 --- verified
firefox112 --- verified

People

(Reporter: dao, Assigned: dao)

References

(Blocks 1 open bug)

Details

(Whiteboard: [snt-urlbar-result-menu])

Attachments

(1 file)

From https://phabricator.services.mozilla.com/D161776:

while pressing down to go down the list of results, it focuses on each meatball menu button. That could mess up users' muscle memory. I recognize that the placeholder is shown on each result because the logic of showing/adding the button on a result will come in future patches, but while testing this I found it a bit jarring that I had to press down extra times to select a non-heuristic result.

I agree with jteow. I think we discussed that down/up arrow keys should skip this button while tab should not.

I agree with having up/down always go through results, while tab moves through "widgets" inside results.
The only special case may be quick actions, but I think we didn't find the right compromise there yet.

It may be a good idea to coordinate with UX on the best solution here.

Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED

I just wanted to ask / clarify in reply to Marco's point that we may not want to do this for quickactions. I think based on feedback we almost certainly want this behaviour for QuickActions, in that the down arrow would select the first Action when present then move on to the next UrlbarResult as opposed to the next action and tab would be used to select any further buttons / actions.

(In reply to Dale Harvey (:daleharvey) from comment #3)

I just wanted to ask / clarify in reply to Marco's point that we may not want to do this for quickactions. I think based on feedback we almost certainly want this behaviour for QuickActions, in that the down arrow would select the first Action when present then move on to the next UrlbarResult as opposed to the next action and tab would be used to select any further buttons / actions.

I agree. Sorry if I was not clear, I actually meant to delegate the decision to you by saying that "we didn't find the right compromise yet", but I wasn't explicit with that.

Blocks: 1810557
Attachment #9312211 - Attachment description: WIP: Bug 1801298 - Fix down/up arrow behavior with the urlbar result menu button. → Bug 1801298 - Fix down/up arrow behavior with the urlbar result menu button.
Attachment #9312211 - Attachment description: Bug 1801298 - Fix down/up arrow behavior with the urlbar result menu button. → WIP: Bug 1801298 - Fix down/up arrow behavior with the urlbar result menu button.
Attachment #9312211 - Attachment description: WIP: Bug 1801298 - Fix down/up arrow behavior with the urlbar result menu button. → Bug 1801298 - Fix down/up arrow behavior with the urlbar result menu button.
Attachment #9312211 - Attachment description: Bug 1801298 - Fix down/up arrow behavior with the urlbar result menu button. → Bug 1801298 - Fix down/up arrow behavior with the urlbar result menu button. r=adw
Blocks: 1782974
Summary: Fix down/up arrow behavior with the urlbar result menu button → Fix down/up arrow behavior with multiple selectable elements per row
Keywords: blocked-ux
Attachment #9312211 - Attachment description: Bug 1801298 - Fix down/up arrow behavior with the urlbar result menu button. r=adw → Bug 1801298 - Fix down/up arrow behavior with multiple selectable elements per row. r=adw
Blocks: 1810647
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/357170b2f52a
Fix down/up arrow behavior with multiple selectable elements per row. r=adw
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2ef3c1d1f5d8
Fix down/up arrow behavior with multiple selectable elements per row. r=adw
Flags: needinfo?(dao+bmo)
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 111 Branch

Since nightly and release are affected, beta will likely be affected too.
For more information, please visit auto_nag documentation.

Blocks: 1811870
Blocks: 1801389
Regressions: 1814630

Confirming this issue as verified fixed on 112.0a1(20230223094032) and 111.0b4(20230221190142) using Windows 11, macOS 13 and Ubuntu22.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: