Remove "Enabled" column from about:plugins

VERIFIED FIXED in mozilla1.9.3a1

Status

()

defect
--
minor
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: jg, Assigned: wesongathedeveloper)

Tracking

Trunk
mozilla1.9.3a1
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(3 attachments, 1 obsolete attachment)

Reporter

Description

17 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021029
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021029

about plugins enabled is incorrect

Reproducible: Always

Steps to Reproduce:
1.install java,
disable java in Prefs->advanced

Actual Results:  
see see about:plugins still shows enabled. exit, reload see that about:plugins
still shows enabled

Expected Results:  
should show disabled

Comment 1

17 years ago
I believe about:plugins doesn't say whether a plugin is *enabled* or not - it
says someting about whether mozilla sees it as *installed* or not.
Reporter

Comment 2

17 years ago
Well, there is a column and it is labeled "enabled" :

rpnp.so
    File name: rpnp.so
MIME Type Description Suffixes Enabled
audio/x-pn-realaudio-plugin RealPlayer Plugin Metafile rpm Yes


Shockwave Flash

    File name: libflashplayer.so
    Shockwave Flash 6.0 r60

MIME Type Description Suffixes Enabled
application/x-shockwave-flash Shockwave Flash swf Yes
application/futuresplash FutureSplash Player spl Yes

Comment 3

17 years ago
You are absolutely right! Sorry.
Disabling java in prefs still leaves it appear as "Enabled" in about:plugins. Odd.

Comment 4

17 years ago
I believe "enabled" actually means that "this mime type will be handled
by this plug-in"
Assignee: beppe → oeschger
Severity: normal → minor
Status: UNCONFIRMED → NEW
Component: Plug-ins → Help
Ever confirmed: true
QA Contact: shrir → tpreston
Summary: about plugins enabled is incorrect → About:plugins "Enabled" column should be "Handled"
Reporter

Comment 5

17 years ago
Hi,
Thanks for your comments.

I can not see the reason for a "handled" column, as it will always be "Yes"
(unless there is some way i do not know of)

If it is renamed Handled, i think there should be another column added to really
show the enabled status.

Regards

JG
Reporter

Comment 6

17 years ago
Any progress on this anyone?
Regards

JG

Comment 7

17 years ago
This is not a Help bug.
Component: Help → Browser-General
moving stuff over to an outside-the-firewall email for the time being, looking
for people to pick these Help and doc bugs up for me.
Assignee: oeschger → oeschger
Product: Browser → Seamonkey

Comment 9

13 years ago
*** Bug 339757 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Assignee: oeschger → nobody
Component: General → Plug-ins
Product: Mozilla Application Suite → Core
QA Contact: tpreston → plugins
*** Bug 339537 has been marked as a duplicate of this bug. ***
Assignee

Comment 11

10 years ago
Posted patch Patch (obsolete) — Splinter Review
Assignee: nobody → wesongathedeveloper
Status: NEW → ASSIGNED
Attachment #421781 - Flags: review?(joshmoz)

Comment 12

10 years ago
Comment on attachment 421781 [details] [diff] [review]
Patch

I don't know what this column is for, but if it is really useless we should just remove it. Changing the name from "Enabled" to "Handled" doesn't make this much more clear.
Attachment #421781 - Flags: review?(joshmoz) → review-

Comment 13

10 years ago
The file for about:plugins is here:

/toolkit/content/plugins.html

Seems like we can just kill that column. Disabled plugins don't show up in about:plugins so we wouldn't be listing MIME types for disabled plugins.
Does it have anything to do with determining which plugin wins when multiple ones handle the same mimetype?
Assignee

Comment 15

10 years ago
(In reply to comment #14)
> Does it have anything to do with determining which plugin wins when multiple
> ones handle the same mimetype?

Yes, I think so - at least based on my understanding of the comment at http://mxr.mozilla.org/mozilla-central/source/browser/components/preferences/applications.js#1089 and the source at http://mxr.mozilla.org/mozilla-central/source/toolkit/content/plugins.html#148
Assignee

Comment 16

10 years ago
Posted patch PatchSplinter Review
Attachment #421781 - Attachment is obsolete: true
Attachment #422130 - Flags: review?(joshmoz)

Comment 17

10 years ago
No need to guess about whether or not that column helps with matching MIME types - it doesn't. I made two plugins with the same handled MIME types and both show up as enabled in a FF 3.6 nightly. This column is useless as far as I can tell.

Comment 18

10 years ago
Comment on attachment 422130 [details] [diff] [review]
Patch

This patch looks good to me, lets get jst to look at it too in case he knows what this column was supposed to be for.
Attachment #422130 - Flags: review?(jst)
Attachment #422130 - Flags: review?(joshmoz)
Attachment #422130 - Flags: review+
Comment on attachment 422130 [details] [diff] [review]
Patch

Yeah, I see no reason to keep this column. The one plugin that I see where we say "No" in the enabled column is for the default plugin, which we're getting rid of completely anyways.
Attachment #422130 - Flags: review?(jst) → review+
Assignee

Updated

10 years ago
Keywords: checkin-needed
Assignee

Updated

10 years ago
Keywords: checkin-needed
Assignee

Updated

10 years ago
Attachment #422130 - Flags: ui-review?(faaborg)
Attachment #422130 - Flags: ui-review?(faaborg) → ui-review+
Assignee

Updated

10 years ago
Keywords: checkin-needed
Summary: About:plugins "Enabled" column should be "Handled" → Remove "Enabled" column from about:plugins
http://hg.mozilla.org/mozilla-central/rev/89bc4e50e4b5
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a1
Well since your removing the column, it begs the question of a new bug which why is this a list of installed plugins and not enabled plugins?

You know its funny that the enabled column would actually make sense if we didn't actually hide disabled plugins on an installed plugins page.

Seeing how the top of the page says installed plugins, but in reality its showing users the list of enabled plugins with the exception of the default.

I guess there must have been a bug to change to list from installed to show only enabled. Why? It seems to me that that is the question, because we also just landed a change to the text when disabling all plugins to say no enabled plugins found [to display on this page].

And then this about:plugins page should really say "Enabled Plugins" because its no longer the "Installed Plugins"..

Comment 23

10 years ago
are yes_label and no_label from plugins.properties still being used anywhere?
Verified fixed using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20100204 Minefield/3.7a1pre, Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a1pre) Gecko/20100204 Minefield/3.7a1pre and latest Win 7 nightly.
Status: RESOLVED → VERIFIED
Assignee

Comment 25

10 years ago
(In reply to comment #23)
> are yes_label and no_label from plugins.properties still being used anywhere?

No they aren't. Good catch.
Attachment #425355 - Flags: review?(joshmoz)

Updated

10 years ago
Attachment #425355 - Flags: review?(joshmoz) → review+
Assignee

Updated

10 years ago
Keywords: checkin-needed
(In reply to comment #22)
> And then this about:plugins page should really say "Enabled Plugins" because
> its no longer the "Installed Plugins"..

FYI, This was changed in bug 548481 to match since bug 496198 also landed.
You need to log in before you can comment on or make changes to this bug.