Closed Bug 1805807 Opened 1 year ago Closed 1 year ago

Message thread breaks when selecting a folder with fewer messages than the previous

Categories

(Thunderbird :: Mail Window Front End, defect)

defect

Tracking

(thunderbird_esr102 unaffected)

RESOLVED FIXED
111 Branch
Tracking Status
thunderbird_esr102 --- unaffected

People

(Reporter: aleca, Assigned: darktrojan)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

This is exclusive to the Ash repository.

STR

  • Select a folder with a lot of messages (in my case it was Trash)
  • Scroll to the bottom of the message list
  • Select another folder that has fewer messages

The tree explodes with multiple: JavaScript error: chrome://messenger/content/tree-view-listbox.mjs, line 1037: TypeError: can't access property "previousElementSibling" of null

We should enforce a scrollToTop() on the TreeView when the folder selection is changed, or an optional boolean to scroll back to the top when the list is invalidated.

Assignee: nobody → geoff
Status: NEW → ASSIGNED

Also: set up the columns before setting the view.

Depends on D167639

Duplicate of this bug: 1812112

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/540de7697f73
Fix error when changing TreeViewListbox's view. r=aleca
https://hg.mozilla.org/comm-central/rev/e5715072b71a
When switching folders, invalidate the thread tree before setting the view. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 111 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: