If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

áéíóúàèìòùÁÉÍÓÚÀÈÌÒÙ in text causes universal AD to display in Big5

VERIFIED FIXED

Status

()

Core
Internationalization
--
trivial
VERIFIED FIXED
15 years ago
10 years ago

People

(Reporter: Niklas Dougherty, Assigned: Shanjian Li)

Tracking

({intl})

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20021031
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20021031

ביםףתאטלעשֱֹֽ׃�ְָּׂ� should provoke universal autodetect to display using
traditional Chinese.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

15 years ago
Yep, this page was displayed in Big5.
Summary: test (ביםףתאטלעשֱֹֽ׃�ְָּׂ�) → ביםףתאטלעשֱֹֽ׃�ְָּׂ� in text causes universal AD to display in Big5
To intl.  What did you expect the behavior to be, exactly?  Does that byte
sequence _ever_ come up in real ISO-8859-* text?  ;)
Assignee: asa → smontagu
Component: Browser-General → Internationalization
QA Contact: asa → ylong

Updated

15 years ago
Keywords: intl
(Reporter)

Comment 3

15 years ago
Yep, it just came up in another bug report. There are instances when such
enumerations are made.

Some wild guessing going on in AD, since a few of the sequences are not valid
Big5 anyway. What's up with this Taiwanese preoccupation?
Assigning autodetection issue to shanjian and reducing severity.
Assignee: smontagu → shanjian
Severity: normal → trivial
(Assignee)

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 5

15 years ago
accept the bug.
Status: NEW → ASSIGNED
(Assignee)

Comment 6

15 years ago
Created attachment 106897 [details] [diff] [review]
patch

This bug reveals a place where universal detector can improve. The patch is
very simple, and it fixes the problem.
(Assignee)

Comment 7

15 years ago
roy, could you r=?

Comment 8

15 years ago
Comment on attachment 106897 [details] [diff] [review]
patch

/r=yokoyama
Attachment #106897 - Flags: review+

Updated

15 years ago
Blocks: 157673
(Assignee)

Comment 9

15 years ago
chris, could you sr?
Summary: ביםףתאטלעשֱֹֽ׃�ְָּׂ� in text causes universal AD to display in Big5 → ביםף�טלעשֱֹֽ׃�ְ�ׂ� in text causes universal AD to display in Big5

Updated

15 years ago
Summary: ביםף�טלעשֱֹֽ׃�ְ�ׂ� in text causes universal AD to display in Big5 → ביםףתאטלעשֱֹֽ׃�ְָּׂ� in text causes universal AD to display in Big5
Attachment #106897 - Flags: superreview+
(Assignee)

Comment 10

15 years ago
fix checked in. 
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 11

15 years ago
Verified this page is detected as windows-1252 and all the accent characters are
displayed fine on 11-27 trunk build / Win2k.
Status: RESOLVED → VERIFIED

Updated

15 years ago
No longer blocks: 157673

Updated

15 years ago
Depends on: 180372
I think the text here was originally áéíóúàèìòùÁÉÍÓÚÀÈÌÒÙ
Summary: ביםףתאטלעשֱֹֽ׃�ְָּׂ� in text causes universal AD to display in Big5 → áéíóúàèìòùÁÉÍÓÚÀÈÌÒÙ in text causes universal AD to display in Big5
You need to log in before you can comment on or make changes to this bug.