Last Comment Bug 181250 - Cookie Manager: display only current page
: Cookie Manager: display only current page
Status: RESOLVED WONTFIX
:
Product: Core
Classification: Components
Component: Networking: Cookies (show other bugs)
: Trunk
: x86 Windows XP
: -- enhancement with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 199450 216379 (view as bug list)
Depends on:
Blocks: 222559
  Show dependency treegraph
 
Reported: 2002-11-21 01:01 PST by Henrik Gemal
Modified: 2016-01-06 11:25 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Henrik Gemal 2002-11-21 01:01:15 PST
One feature I really really miss is the ability to see the cookies that are used
on the current page and/or site. I hate having to go though the entire cookie
list in Cookie Manager to delete all cookies related to the loaded site.
Cookies and be listet under both the current domain and the current site name.

I'd like a filtering option to allow only current used cookies to be shown for
the current or a selected windows/tab
Comment 1 Patrick 2002-11-21 07:59:29 PST
there used to be this cookie indicator on the status bar...i think it even made
it into Netscape 7. Probably there's something on this somewhere in bugzilla
already?
Comment 2 Stephen P. Morse 2002-11-21 10:14:24 PST
How do you define "current page".  Is it just the item in the URL line?  How
about all included items such as images?  Then how about any cookies that were
set through some redirects on the way to the current page?  Such cookies would
be very hard to keep track of.

The latter is not an uncommon scenario.  Some websites do a redirect to
double-click which sets a cookie and then redirects back to the original site
(the original site's url was passed in the query string to doubleclick).

Regarding the cookie icon -- that was something entirely different.  It
indicated if any cookies ever (not just the current page) had a cookie decision
changed because of the p3p setting.  And the icon still exists in N7 but it not
in Netscape.  And it's no longer a cookie icon -- rather it's an "eye" (don't
ask me how anybody is supposed to know what that means).
Comment 3 Michiel van Leeuwen (email: mvl+moz@) 2003-04-06 11:29:20 PDT
*** Bug 199450 has been marked as a duplicate of this bug. ***
Comment 4 Alfonso Martinez 2003-08-16 12:42:31 PDT
*** Bug 216379 has been marked as a duplicate of this bug. ***
Comment 5 Eliot Lear 2003-08-16 14:45:00 PDT
Regarding Comment 2

Show all cookies generated through the visiting of the current URL.  As it
stands cookie notification is rather useless since it pops up so often and
provides no specific information about the page visited.

Thanks.
Comment 6 Mike Connor [:mconnor] 2004-04-04 12:04:54 PDT
-> me, futuring to coexist with some of the plans that are stewing for statusbar
controls
Comment 7 Mike Connor [:mconnor] 2005-09-07 12:39:41 PDT
Not going to be working on any Seamonkey UI bugs for the foreseeable future. 
You can filter on "danlikesgoats" to delete this spam.
Comment 8 Ian Macfarlane 2005-11-22 06:59:08 PST
See the Firefox extension 'View cookies' that does this by adding a tab in the Page Info window.

http://www.bitstorm.org/extensions/view-cookies/

Note You need to log in before you can comment on or make changes to this bug.