Closed Bug 1815026 Opened 4 months ago Closed 2 months ago

message selection in modest size folder and larger is sluggish

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 111
defect

Tracking

(thunderbird_esr102 unaffected)

RESOLVED WORKSFORME
Tracking Status
thunderbird_esr102 --- unaffected

People

(Reporter: mkmelin, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Keywords: perf, Whiteboard: [Supernova3p])

Clicking from one message to another in a folder with moderate size (bugmail, around 70k msgs) is sluggish. It takes almost a second before the highlighted message changes to the selected one in the list. That's just too slow. I expect the selected message highlight to be instantaneous, after which the actual message load can take it own time.
For small folders, I don't see much of a delay.

Profile:https://share.firefox.dev/3Y5VEcx
This was from a test profile, where it's not actually that noticeable. Shows jank of around 400ms for a select though.

Whiteboard: [Supernova]
Version: unspecified → Thunderbird 111
Blocks: sn-msglist

How is this after Bug 1814320 has delivered a couple patches?

Flags: needinfo?(mkmelin+mozilla)

It hasn't changed at least very much.

Flags: needinfo?(mkmelin+mozilla)
No longer depends on: 1814320
Severity: -- → S4

Does this reproduce with 112 beta?
Can you profile this on something other than Linux?
Or re-profile, and note at what specific seconds during the profile you selected a new message
Make sure you pick the Thunderbird presets per https://support.mozilla.org/en-US/kb/profiling-thunderbird-performance

Flags: needinfo?(mkmelin+mozilla)
Summary: message list navigation is sluggish → message selection in modest size folder and larger is sluggish

At least on daily it does seem gone. Not sure when it got better since I larger retrained myself not to use mouse for message selection.

Status: NEW → RESOLVED
Closed: 2 months ago
Flags: needinfo?(mkmelin+mozilla)
Resolution: --- → WORKSFORME
Whiteboard: [Supernova] → [Supernova3p]
You need to log in before you can comment on or make changes to this bug.