Closed Bug 1814320 Opened 1 year ago Closed 1 year ago

Clean up the tree view listbox code for the about3Pane

Categories

(Thunderbird :: Folder and Message Lists, enhancement)

Thunderbird 111
enhancement

Tracking

(thunderbird111 fixed)

RESOLVED FIXED
112 Branch
Tracking Status
thunderbird111 --- fixed

People

(Reporter: aleca, Assigned: aleca)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Supernova3p])

Attachments

(1 file)

Here's a good place we can use for exploring how to improve the performance of our new TreeViewListbox.

These are some fairly low hanging fruit we can start adding:

  • If we're dealing with the subjectCol, use cellTextForColumn only once to set the text in the column and the aria-label for the row. Fetching the subject text twice is expensive.
  • We should have a single <template> with all the cells of the message thread, and when constructing the row on connectedCallback(), extract those cells from the template and add them to a DocumentFragment based on the Columns::ordinal, and then append it all at once. Avoid replacing or creating new DOM.Nodes inside the set index() method.

Anything else that comes to mind?

Keywords: perf
Assignee: nobody → alessandro
Status: NEW → ASSIGNED
Keywords: leave-open
Whiteboard: [Supernova]

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/26f62abc23bf
Clean up the tree view listbox code for the about3Pane. r=darktrojan

Comment on attachment 9317172 [details]
Bug 1814320 - Clean up the tree view listbox code for the about3Pane. r=darktrojan

[Approval Request Comment]
Regression caused by (bug #): Supernova

Attachment #9317172 - Flags: approval-comm-beta?

Comment on attachment 9317172 [details]
Bug 1814320 - Clean up the tree view listbox code for the about3Pane. r=darktrojan

[Triage Comment]
Approved for beta

Attachment #9317172 - Flags: approval-comm-beta? → approval-comm-beta+
Depends on: 1819010
Depends on: 1819013
Type: enhancement → defect

Converting this into a meta bug to avoid crossing versions.
Blockers of this have been added and Geoff is tackling the most obvious downfalls.

Assignee: alessandro → nobody
Status: ASSIGNED → NEW
Keywords: leave-openmeta
Summary: Improve the performance of the new TreeViewListbox → [meta] Improve the performance of the new TreeViewListbox
Depends on: 1819137
Blocks: sn-treeperf
Assignee: nobody → alessandro
No longer blocks: 1815026, sn-treeperf
Status: NEW → RESOLVED
Type: defect → enhancement
Closed: 1 year ago
No longer depends on: 1819010, 1819013, 1819137
Keywords: meta, perf
Resolution: --- → FIXED
Summary: [meta] Improve the performance of the new TreeViewListbox → Clean up the tree view listbox code for the about3Pane
Whiteboard: [Supernova] → [Supernova3p]
You need to log in before you can comment on or make changes to this bug.