Closed Bug 1815645 Opened 1 year ago Closed 1 year ago

Reimplement drag and drop of messages and folders

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 111
defect

Tracking

(thunderbird_esr102 unaffected, thunderbird111 fixed)

RESOLVED FIXED
111 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird111 --- fixed

People

(Reporter: darktrojan, Assigned: darktrojan)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [Supernova3p])

Attachments

(3 files)

Title says it all. This has not been implemented yet.

This is largely the same as the code removed here:
https://hg.mozilla.org/comm-central/diff/7ad0631d10830f02972932ff3957c88a3a8f3e5f/mail/base/content/msgMail3PaneWindow.js#l1.139

It should be enough to enable copying messages to the filesystem. The contents of the dataTransfer
object aren't exactly the same as before, I've removed some complexity, and for some reason
text/x-moz-message can't be used by the flavor data provider, so I've added text/plain.

Duplicate of this bug: 1815948

QA will want to look at this for functional and dataloss potential.

Flags: needinfo?(bugzilla2007)

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/4203972669d2
Reimplement dragging messages from the thread pane. r=freaktechnik
https://hg.mozilla.org/comm-central/rev/86981acac04c
Reimplement dropping messages on folders. r=freaktechnik

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

comm/mail/test/browser/tabmail/browser_dragndrop.js is now failing on mac

Flags: needinfo?(geoff)

Ah, it was failing even before these two landed.

Flags: needinfo?(geoff)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [Supernova]

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/8fec4cdfd92c
Reimplement dragging and dropping folders. r=aleca

Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED

Comment on attachment 9317533 [details]
Bug 1815645 - Reimplement dragging and dropping folders. r=#thunderbird-front-end-reviewers

[Approval Request Comment]
Regression caused by (bug #): Supernova

Attachment #9317533 - Flags: approval-comm-beta?

Comment on attachment 9317533 [details]
Bug 1815645 - Reimplement dragging and dropping folders. r=#thunderbird-front-end-reviewers

[Triage Comment]
Approved for beta

Attachment #9317533 - Flags: approval-comm-beta? → approval-comm-beta+

(In reply to Wayne Mery (:wsmwk) from comment #4)

QA will want to look at this for functional and dataloss potential.

Seems to work for basic cases.

Tested:

  • drag single message into another folder (IMAP > IMAP, IMAP > local) -> OK
  • drag multiple messages into another folder (IMAP > IMAP, IMAP > local) -> OK
  • drag folder with multiple messages (IMAP > IMAP, IMAP > local) -> OK
  • drag closed thread (IMAP > IMAP, IMAP > local) -> OK

Some buggy observations

  • Some of these actions sometimes appeared to have significant delays of up to several seconds with only 2 small messages, then not
  • All my Gmail Inbox subfolders (Friends & Family, Social Media, Work and custom folders) have weird order of columns: (starred, read) From (spam) Subject, Date. Thread missing, From shouldn't be there, Correspondents should afasik. Weirdly, we don't seem to have an action for restoring the default set?? Eventually I ended up with all small columns in front - Restore column order doesn't change that, which looks like a bug - filed Bug 1817867.
  • Eventually appeared to have lost 1 message, but not exactly sure how. Maybe dragging (thread?) back from local Trash to Imap. Can't reproduce.
  • After restarting Daily, the weird columns thing had also crawled into my IMAP inbox. Then checked and saw 99% CPU in Task manager for a sec before it went down, apparently from something unrelated like "Microsoft Text Input...". Now I have weird set of columns with weird order and I cannot change that, as columns also cannot be reordered yet.
  • Also met Bug 1817871 on the way.
Flags: needinfo?(bugzilla2007)
See Also: → 1820009

Please land the last patch on beta.

Flags: needinfo?(daniel)
Flags: needinfo?(daniel)
Whiteboard: [Supernova] → [Supernova3p]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: