Closed Bug 1817109 Opened 1 year ago Closed 1 year ago

Folder modes menu items missing in folder pane options meatballs menu

Categories

(Thunderbird :: Message Reader UI, defect, P3)

Thunderbird 111

Tracking

(thunderbird111? unaffected, thunderbird112 fixed)

VERIFIED FIXED
113 Branch
Tracking Status
thunderbird111 ? unaffected
thunderbird112 --- fixed

People

(Reporter: thomas8, Assigned: solange)

References

(Blocks 1 open bug)

Details

(Keywords: access, regression, Whiteboard: [Supernova3p])

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #1817099 +++

112.0a1 (2023-02-15) (64-bit), Win10

STR

  • Click meatballs menu in Folder Pane Header with intention of adding/changing visibility of (multiple) folder modes

Actual:

  • Folder modes menu items no longer on the menu
  • Only available (and functional) on main menu

Expected

  • Restore folder modes menu items in folder pane options meatballs menu

Not fatal, but should restore this soonish as it's relevant for basic UI choices.

We already have bug 1812403, which is a bit of a catch all, not sure if this can be considered a duplicate

Folder pane options in TB 111 vs. TB 102. We need to merge both menus, and ensure nothing is missing.

(In reply to Alessandro Castellani [:aleca] from comment #1)

We already have bug 1812403, which is a bit of a catch all, not sure if this can be considered a duplicate

Yes, thanks. Maybe we want to keep this separate until the deed is done, because it's a regression from status quo and beta testers might complain about this. They won't miss new entries which they don't know yet.

Type: task → defect
Depends on: sn-fp-options
Summary: Restore folder modes menu items in folder pane options meatballs menu → Folder modes menu items missing in folder pane options meatballs menu
Keywords: regression

Solange, assigning this to you.
The objective here is to add the Folder Modes submenu in the meatball menupopup.

Assignee: nobody → solange
Attachment #9319548 - Attachment description: WIP: Bug 1817109 - Folder modes menu items missing in folder pane options meatballs menu. → Bug 1817109 - Folder modes menu items missing in folder pane options meatballs menu. r=aleca,micahilbery
Attachment #9319548 - Attachment description: Bug 1817109 - Folder modes menu items missing in folder pane options meatballs menu. r=aleca,micahilbery → WIP: Bug 1817109 - Folder modes menu items missing in folder pane options meatballs menu.
Attachment #9319548 - Attachment description: WIP: Bug 1817109 - Folder modes menu items missing in folder pane options meatballs menu. → Bug 1817109 - Folder modes menu items missing in folder pane options meatballs menu. r=aleca,micahilbery
Attachment #9319548 - Attachment description: Bug 1817109 - Folder modes menu items missing in folder pane options meatballs menu. r=aleca,micahilbery → WIP: Bug 1817109 - Folder modes menu items missing in folder pane options meatballs menu.
Attachment #9319548 - Attachment description: WIP: Bug 1817109 - Folder modes menu items missing in folder pane options meatballs menu. → Bug 1817109 - Folder modes menu items missing in folder pane options meatballs menu. r=aleca,micahilbery
Target Milestone: --- → 113 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/d569f7fe35e6
Folder modes menu items missing in folder pane options meatballs menu. r=aleca

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Comment on attachment 9319548 [details]
Bug 1817109 - Folder modes menu items missing in folder pane options meatballs menu. r=aleca,micahilbery

[Triage Comment]
Approved for beta

Attachment #9319548 - Flags: approval-comm-beta+

Thanks much Sol for restoring this important functionality and writing up the tests!

Verified working correctly on 113.0a1 (2023-03-22) (64-bit), Win10.

Status: RESOLVED → VERIFIED
See Also: → 1826443
Whiteboard: [Supernova] → [Supernova3p]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: