Closed Bug 1819104 Opened 1 year ago Closed 1 year ago

Cannot drag message list columns to reorder them

Categories

(Thunderbird :: Folder and Message Lists, defect, P2)

Thunderbird 111
Desktop
All

Tracking

(thunderbird_esr102 unaffected, thunderbird112+ fixed, thunderbird113 affected)

VERIFIED FIXED
113 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird112 + fixed
thunderbird113 --- affected

People

(Reporter: bugzilla, Assigned: aleca)

References

(Blocks 1 open bug)

Details

(Keywords: regression, ux-discovery, Whiteboard: [Supernova3p])

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/111.0

Steps to reproduce:

New Thunderbird beta version has message columns in an order that I do not like. I cannot drag the columns to reorder them as I expected. Version 111.0b1 for Ubuntu, snap build.

Actual results:

Click and hold on a header. Move while holding to the left or right. Instead of moving the column, it highlights the other headers.

Expected results:

Dragging a column should move it.

Thanks Shawn, yes, dragging columns hasn't been restored yet. In the meantime, you can press Tab key until you reach the column headers of folder list, and then use Alt+arrow-left/right to move the focused column (implemented by bug 1803272).

Confirming for TB 112.0a1 (2023-02-27) (64-bit), Win10.

We should restore this feature because keyboard reordering is not easy to discover, and much less direct than dragging.

Blocks: sn-msglist
Severity: -- → S3
Status: UNCONFIRMED → NEW
Component: Untriaged → Folder and Message Lists
Ever confirmed: true
See Also: → 1803272
Summary: Cannot drag message list columns to reorder them in Thunderbird Beta for Linux, resizing works → Cannot drag message list columns to reorder them
Whiteboard: [supernova]

I'm seeing many of my folders with odd column combinations and order, and I will want to fix those folders to make them usable.
Not a blocker, but I'd say this is going to be high on beta users' "highly irritating" list.

Priority: -- → P1
Assignee: nobody → alessandro
Flags: needinfo?(bugzilla)

The keyboard instructions provided here did not work. I'm on Linux, and don't have immediate access to my Windows machine to try it there. Is it maybe not all cross-platform?

Flags: needinfo?(bugzilla)

(In reply to Shawn Heisey from comment #3)

The keyboard instructions provided here did not work. I'm on Linux, and don't have immediate access to my Windows machine to try it there. Is it maybe not all cross-platform?

Matt, does keyboard ordering fail for you on linux - beta or daily? Works for me on Windows and Mac

Flags: needinfo?(unicorn.consulting)
See Also: → 1813955

The keyboard instructions fail for me in 111.0b1 on openSuse, they do work on 111.0b2.

Flags: needinfo?(bugzilla)
Flags: needinfo?(bugzilla)
Flags: needinfo?(bugzilla)
Flags: needinfo?(bugzilla)
Flags: needinfo?(bugzilla)
Flags: needinfo?(bugzilla)

The bugzilla page is refreshing automatically and posting a new comment when it does. Each time above I started typing and before I'd gotten two words out, it refreshed the page and showed a new comment added.

Now it seems to have calmed down.

In 111.0b3 the mouse dragging still doesn't work. But this version swapped the Subject and Correspondents columns back to where I wanted them, which is what I was trying to do, because with the subject in the middle of the screen, it's much harder to see the threading caret. The keyboard way does work in this version.

Duplicate of this bug: 1821571
Priority: P1 → P2
Status: NEW → ASSIGNED
OS: Unspecified → All
Hardware: Unspecified → Desktop

This may also be relevant here: bug 1825012

Attachment #9325337 - Attachment description: WIP: Bug 1819104 - Implement drag & drop for tree view table columns. → Bug 1819104 - Implement drag & drop for tree view table columns. r=darktrojan
Attachment #9325337 - Attachment description: Bug 1819104 - Implement drag & drop for tree view table columns. r=darktrojan → Bug 1819104 - Implement drag & drop for tree view table columns. r=#thunderbird-reviewers
Target Milestone: --- → 113 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/83ca6a4ea9cf
Implement drag & drop for tree view table columns. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Duplicate of this bug: 1825191

WFM on nightly

Status: RESOLVED → VERIFIED
Flags: needinfo?(unicorn.consulting)

Comment on attachment 9325337 [details]
Bug 1819104 - Implement drag & drop for tree view table columns. r=#thunderbird-reviewers

[Triage Comment]
Approved for beta

Attachment #9325337 - Flags: approval-comm-beta+
Whiteboard: [supernova] → [Supernova3p]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: