Closed Bug 1820596 Opened 1 year ago Closed 1 year ago

Troubleshooting Information "Copy text to clipboard" doesn't work

Categories

(Thunderbird :: General, defect)

Thunderbird 111
Desktop
All
defect

Tracking

(thunderbird_esr102 unaffected, thunderbird111 wontfix, thunderbird112 fixed, thunderbird113 affected)

RESOLVED FIXED
113 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird111 --- wontfix
thunderbird112 --- fixed
thunderbird113 --- affected

People

(Reporter: raal, Assigned: rjl)

References

(Regression)

Details

(Keywords: platform-parity, regression, Whiteboard: [snnot3p])

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/110.0

Steps to reproduce:

Open Help > Troubleshooting Information
Click button Copy text to clipboard

User Agent Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/112.0 Thunderbird/112.0a1
OS Linux 5.15.0-60-generic #66-Ubuntu SMP Fri Jan 20 14:29:49 UTC 2023

Actual results:

nothing copied to clipboard (clipboard is cleared, so TB is trying to do something)

Expected results:

Informations in clipboard

Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
Summary: copy text to clipboard → Troubleshooting Information "Copy text to clipboard" doesn't work

This WFM on Mac using Thunderbird 111.0b3 and nightly 2023-03-13

Raal, please retest with current nightly. If it fails, then maybe this is linux only

Flags: needinfo?(raal)
Version: Thunderbird 112 → Thunderbird 111
Whiteboard: [snnot]

I'll confirm that "Copy to Clipboard" does not work with Daily (2023-03-14) on Linux w/ GNOME and Wayland. I did not see any errors in the jsconsole.

I can also reproduce the issue on Daily113.0a1 build id20230314105933 Windows10.

OS: Unspecified → All
Hardware: Unspecified → Desktop
Keywords: platform-parity

(In reply to Wayne Mery (:wsmwk) from comment #2)

This WFM on Mac using Thunderbird 111.0b3 and nightly 2023-03-13

Raal, please retest with current nightly. If it fails, then maybe this is linux only

Still doesn't works
Name Thunderbird
Version 113.0a1
Build ID 20230314105933

Flags: needinfo?(raal)

It looks like we need to port bug 1776879. Change "text/unicode" to "text/plain" in the TransferData calls.

Assignee: nobody → rob
Attachment #9323041 - Attachment description: WIP: Bug 1820596 - Port bug 1776879: Replace text/unicode for clipboard and drag and drop and use text/plain directly. → Bug 1820596 - Port bug 1776879: Replace text/unicode for clipboard and drag and drop and use text/plain directly. r=#thunderbird-reviewers
Status: NEW → ASSIGNED
Target Milestone: --- → 113 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/e836da65e651
Port bug 1776879: Replace text/unicode for clipboard and drag and drop and use text/plain directly. r=leftmostcat

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Comment on attachment 9323041 [details]
Bug 1820596 - Port bug 1776879: Replace text/unicode for clipboard and drag and drop and use text/plain directly. r=#thunderbird-reviewers

[Approval Request Comment]
Regression caused by (bug #): 1776879
User impact if declined: Copy to clipboard button in about:support fails
Testing completed (on c-c, etc.): confirmed fixed on Daily
Risk to taking this patch (and alternatives if risky):
medium to high -- the fix involved touching every instance of clipboard and dragdrop transferstreams (or something like that) -- it did follow what upstream did, but random drag/drop stuff could be affected if i goofed

Attachment #9323041 - Flags: approval-comm-beta?

Comment on attachment 9323041 [details]
Bug 1820596 - Port bug 1776879: Replace text/unicode for clipboard and drag and drop and use text/plain directly. r=#thunderbird-reviewers

[Triage Comment]
Approved for beta

Attachment #9323041 - Flags: approval-comm-beta? → approval-comm-beta+
Whiteboard: [snnot] → [snnot3p]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: