Closed Bug 1820604 Opened 1 year ago Closed 1 year ago

Message list no longer fires focus events for screen reader users while navigating

Categories

(Thunderbird :: Folder and Message Lists, defect, P1)

Thunderbird 112

Tracking

(Not tracked)

RESOLVED FIXED
112 Branch

People

(Reporter: pvagner, Assigned: aleca)

References

(Regression)

Details

(Keywords: access, regression)

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/112.0

Steps to reproduce:

  • Open thunderbird with a screen reader running
  • Navigate to the message list with tab / shift+tab or F6 / shift+F6.
  • Once the message list is in focus try to navigate using up and down arrow keys.

Actual results:

Screen reader (orca) on linux reports nothing. Visually the selection is changing.

Expected results:

Assistive tools like screen readers should be notified with active focus.
This used to work in thunderbird daily 20230227 and earlier.

Tested this with Windows Narrator and it works for me. Granted, a lot of unneeded information (like "About message loaded") area read every time, but the message row subject is read. Bug 1813492 should take care of everything.

Micah, can you use Orca on Linux and confirm that the subject line is not read?

Flags: needinfo?(micah)

Peter, would you be able to test a patch if I provide one? Or would you prefer a daily build to lunch locally (not affecting your current profile) to test the applied patch?

Flags: needinfo?(pvagner)
Assignee: nobody → alessandro
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

(In reply to Alessandro Castellani [:aleca] from comment #2)

Peter, would you be able to test a patch if I provide one? Or would you prefer a daily build to lunch locally (not affecting your current profile) to test the applied patch?

I don't have the build environment setup thus I can't build Thunderbird my self. I'm fine with the try build or daily build.

Flags: needinfo?(pvagner)
Severity: -- → S2
Priority: -- → P1
See Also: → 1813492

I think I now have better regression window:
2023-02-27-10-47-16-comm-central fires focus events
2023-02-28-10-51-07-comm-central does not fire focus events when navigating in the message list.

(In reply to Alessandro Castellani [:aleca] from comment #1)

Tested this with Windows Narrator and it works for me. Granted, a lot of unneeded information (like "About message loaded") area read every time, but the message row subject is read. Bug 1813492 should take care of everything.

Micah, can you use Orca on Linux and confirm that the subject line is not read?

I can confirm on daily that the screen reader does nothing and nothing is read when navigating the message list.
Linux - Fedora 37 - Orca screen reader

Flags: needinfo?(micah)
Attachment #9321528 - Attachment description: Bug 1820604 - Focus on the tree items, not the tree table body. r=darktrojan → WIP: Bug 1820604 - Focus on the tree items, not the tree table body.

Micah, can you test this patch with Orca?
it's very rough so things might break, but I'm only interested in the screen reader getting fired properly.

Flags: needinfo?(micah)

There are 2 patches here.
One that implements a tab roving focus on the single rows, the other that fixes the aria-activedescendant problem.

Micah, can you check with Orca the D172066?
I feel that that's gonna be the winner.

I tested both patches and they both seem to trigger the screen reader now and both read the subject line.
Linux - Fedora 37 - Orca screen reader

Flags: needinfo?(micah)
Attachment #9321528 - Attachment is obsolete: true
Regressed by: 1819236
Blocks: 1813492
See Also: 1813492
Target Milestone: --- → 112 Branch

(In reply to Alessandro Castellani [:aleca] from comment #11)

Try run: https://treeherder.mozilla.org/jobs?repo=try-comm-central&revision=b57f5bcdc265ca5f579a537f681dfd0978fb642c

Huge thanks Alesandro I can verify the fix by running the artifact from this run.
It also fixes bug 1819292 for me.

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/b4f6ba603dfd
Fix the a11y of the TreeView active descendant. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Duplicate of this bug: 1819292
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: