Closed Bug 1825207 Opened 1 year ago Closed 1 year ago

Subtitles are not displayed in PiP on TubiTV live streams

Categories

(Toolkit :: Picture-in-Picture, defect)

Desktop
All
defect

Tracking

()

RESOLVED FIXED
115 Branch
Tracking Status
firefox111 --- wontfix
firefox112 --- wontfix
firefox113 --- wontfix
firefox114 --- wontfix
firefox115 --- verified

People

(Reporter: pmagyari, Assigned: kpatenio)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fidefe-pip3])

Attachments

(2 files, 1 obsolete file)

Found in

  • Nightly 113.0a1

Affected versions

  • Beta 112.0b7
  • Release 11.0.1

Affected platforms

  • All

Steps to reproduce

  1. Make sure to use a VPN if not from the US.
  2. Navigate to www.tubitv.com/live
  3. Choose a live-stream from the available ones.
  4. Make sure you have subtitles (CC) activated.
  5. Launch live-stream in PiP mode.

Expected result

  • The subtitles should be displayed in PiP.

Actual result

  • The subtitles are not displayed in PiP.

Regression range

  • This is not a recent regression.

Additional notes

  • Subtitles are properly displayed in PiP in the case of videos that aren't live.
Attached image live fwd-bck.jpg

Additional Note

  • Progress bar and Forwards/Backward buttons are also available while watching liveTV.
Whiteboard: [fidefe-pip3]
See Also: → 1828705

For TubiTV live, we're able to utilize the textTracks video property to detect active cues. We support this property in the PiPChild. However, the cues are set to hidden mode since TubTV live allows for customizing captions appearance.

We only support showing mode tracks at the moment, but there is ongoing work to support hidden tracks in Bug 1754549.

Assignee: nobody → kpatenio
Status: NEW → ASSIGNED

While the override showHiddenTextTracks works in showing captions on TubiTV live videos, captions are still displayed on the PiP window when TubiTV live cc is disabled since the text track mode remains as hidden (thus never triggering the change event). Unfortunately I didn't realize this until I started working on a patch. The easiest workaround probably would be to detect captions via a site-specific wrapper. We already have a wrapper for tubiTV, but we might want a separate one unique to tubiTV live given Bug 1828705.

Attachment #9331211 - Attachment description: WIP: Bug 1825207 - add subtitles support for TubiTV live. r=#pip-reviewers!,dwalker! → Bug 1825207 - add subtitles support for TubiTV live. r=#pip-reviewers!,dwalker!
Blocks: 1765604
Pushed by kpatenio@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1fb145fdba3e
add subtitles support for TubiTV live. r=pip-reviewers,dwalker,mhowell
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 115 Branch

I have verified the fix using Nightly 115.0a1 (20230508214159) on Window 10, MacOS 11 and Ubuntu 20.04.

a11y-review: --- → requested

Since nightly and release are affected, beta will likely be affected too.
For more information, please visit BugBot documentation.

Is a11y-review needed here? The patch merely adds a script to support visually displaying captions on TubiTV Live, which we've done for other sites that previously did not require a11y-review. It also shouldn't impact accessibility of keyboard tabbing, screen readers, etc.

It is just some spammer or would be security tester.

a11y-review: requested → ---

The patch landed in nightly and beta is affected.
:kpatenio, is this bug important enough to require an uplift?

  • If yes, please nominate the patch for beta approval.
  • If no, please set status-firefox114 to wontfix.

For more information, please visit BugBot documentation.

Flags: needinfo?(kpatenio)
Flags: needinfo?(kpatenio)
Attachment #9341367 - Attachment description: WIP: Bug 1825207: PiP subtitle fix for hotstar → Bug 1825207: PiP subtitle fix for Disney+ Hotstar
Attachment #9341367 - Attachment description: Bug 1825207: PiP subtitle fix for Disney+ Hotstar → WIP: Bug 1825207: PiP subtitle fix for hotstar

A patch has been attached on this bug, which was already closed. Filing a separate bug will ensure better tracking. If this was not by mistake and further action is needed, please alert the appropriate party. (Or: if the patch doesn't change behavior -- e.g. landing a test case, or fixing a typo -- then feel free to disregard this message)

Attachment #9341367 - Attachment description: WIP: Bug 1825207: PiP subtitle fix for hotstar → Bug 1825207: PiP subtitle fix for Disney + Hotstar
Attachment #9341367 - Attachment description: Bug 1825207: PiP subtitle fix for Disney + Hotstar → Bug 1840583: PiP subtitle fix for Disney + Hotstar

Comment on attachment 9341367 [details]
Bug 1840583: PiP subtitle fix for Disney + Hotstar

Revision D182252 was moved to bug 1840583. Setting attachment 9341367 [details] to obsolete.

Attachment #9341367 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: