Closed Bug 1826379 Opened 11 months ago Closed 11 months ago

Update PDF.js to new version 184076fe7acfae9c1e5938151d5d4f95e9e94ea5 from 2023-04-04 16:29:23

Categories

(Firefox :: PDF Viewer, enhancement)

Firefox 113
enhancement

Tracking

()

RESOLVED FIXED
113 Branch
Tracking Status
firefox113 --- fixed

People

(Reporter: calixte, Assigned: calixte)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

#16188 Use the position of the previous xref stream if any when saving a pdf (bug 1823296)
#16186 Support multi-byte ToUnicode entries, when using predefined CMaps (issue 16176)
#16191 Track previous "XRefStm"s in a Set, rather than an Object
#16193 Add even more non-standard ligatures (PR 15517 follow-up)
#16173 Introduce inset usage in the CSS files
#16182 Introduce inset-block usage in the viewer CSS
#16192 Use cursor:move for draggable texts and drawings (Bug 1804252)
#16196 Use String.prototype.replaceAll() where appropriate
#16198 Reduce some duplication in the PDFViewer.{increaseScale, decreaseScale} methods
#16185 Enable the unicorn/prefer-negative-index ESLint plugin rule
#16208 Use replaceAll in the recoverJsURL helper function
#16207 Enable the declaration-block-no-redundant-longhand-properties Stylelint rule
#16206 Update packages and translations
#16199 Slightly reduce the size of the FontInspector-integration in the API
#16211 Fix spelling of occurred in a couple of comments
#16212 [GeckoView] Remove unused transition CSS-rules
#16217 ESMify some modules for m-c (bug 1824610)
#16218 Simplify the isPDFFunction helper function
#16213 Reduce duplication in the validateCSSFont helper function
#16223 Create a new chunk when the char is too rised compared to the previous one
#16227 Fix various zooming regressions (PR 15812 follow-up)
#16228 [Firefox] Set the imageResourcesPath correctly (PR 16153 follow-up)
#16235 Remove now unnecessary eslint-disable statement generated for PdfJsDefaultPreferences.sys.mjs. (bug 1825522).
#16234 [api-minor] Remove the disableCombineTextItems option
#16238 Update the Node.js compatibility-check in the worker-thread
#16232 [Firefox] Stop using a baseUrl in the PDFLinkService (PR 16153 follow-up)
#16159 Write some {Object} in api.js more precise
#16243 Use object-spread when dispatching events in the toolbars
#16242 [api-minor] Remove the canvasFactory option from PDFPageProxy.render (PR 16100 follow-up)
#16244 Bump versions in pdfjs.config
#16248 Reduce duplication when dispatching the "switchannotationeditorparams" event
#16226 [api-minor] Remove SVG-rendering from the viewer (PR 15173 follow-up)

Pushed by cdenizet@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/223e3b017232
Update PDF.js to new version 184076fe7acfae9c1e5938151d5d4f95e9e94ea5 r=pdfjs-reviewers,marco
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 113 Branch
Duplicate of this bug: 1826399
Blocks: 1830645
You need to log in before you can comment on or make changes to this bug.