Closed Bug 1830439 Opened 1 year ago Closed 7 months ago

Quick filter tag bar doesn't refresh when other quick filter conditions change - too many or too few tags shown

Categories

(Thunderbird :: Search, defect)

Thunderbird 114
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1846359

People

(Reporter: thomas8, Unassigned)

References

(Blocks 1 open bug)

Details

(4 keywords, Whiteboard: [snnot3p][datalossy])

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #612800 +++

Refiling bug 612800 which struck me again in Supernova. Maybe with the new quickfilter UI, we can finally fix this after more than a decade - I assume it's actually pretty easy to fix.

Tag filter is supposed to show any tags found on the current result set of messages as defined by any other quick filter conditions. So whenever those other conditions change, i.e. the result set of messages changes, quick filter tag bar must be updated as there might be more or less tags present on the changed result set. Unfortunately, this doesn't happen: tag bar only updates when you first open it, so the tab bar may show the wrong set of tags whenever other conditions change while the tab bar is already present.

STR

  1. Create test folder with 4 messages:
  • msg1: Starred and tagged important (red)
  • msg2: Starred and tagged todo (blue)
  • msg3: Starred and not tagged
  • msg3: Not starred, but tagged personal (green)
  1. Now start quick filtering:
  • a) click tagged filter button
    -> returns the 3 tagged messages and shows only the tags present on those: msg1, msg2, msg4 - tag bar shows tags Important, Todo, Personal (ok)
  • b) then click starred filter button
    -> returns 2 starred and tagged messages: msg1, msg2 (OK)
    -> However, keeps claiming that the current result set still has 3 different tags including Personal, but there's no message in result set any more having that tag (this bug).
  • c) click tagged button to remove that condition
    -> only the 3 starred messages shown (OK)
  • d) click tagged button to re-apply that condition again
    -> returns 2 starred and tagged messages (OK)
    -> However, this time correctly returns only two tags, Important and Todo - same filter state as in b), but less tags (this bug).

Actual results:

  • see STR
  • tag bar is being not updated when other filter criteria change, so the stale set may show more or less tags than actually found on result messages.
  • Depending on the sequence in which search criteria are applied, the same set of filter criteria may display different tags allegedly on the messages of the result set or not, which is inconsistent and confusing.
  • The incorrect display of tags present on result set is highly error-prone and may mislead the user into wrong actions based on false assumptions about the current result set, such as unintentional deletion, which is dataloss.

Expected results:

  • Whenever any other filter criterion except tasks changes, we must update the tags bar (if visible) to reflect only the tags which are present on the result set.
  • As a caveat, when updating tags bar, we must maintain any tags which have been selected on the tags bar.
  • Same filter UI state should always return the same result regardless of the sequence in which criteria have been activated - anything else is confusing.
Duplicate of this bug: 612800

Are we really sure this isn't supernova related?
If it isn't supernova, we should change the version number.

We're completely changing this behaviour so the current UI will be outdated soon (post 115)

Status: NEW → RESOLVED
Closed: 7 months ago
Duplicate of bug: 1846359
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: