Closed Bug 1831224 Opened 10 months ago Closed 10 months ago

Dragging message from advanced `Search Messages` dialogue to desktop doesn't work

Categories

(Thunderbird :: Search, defect, P2)

Thunderbird 114

Tracking

(thunderbird_esr102 unaffected, thunderbird114 fixed)

VERIFIED FIXED
115 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird114 --- fixed

People

(Reporter: betterbird.project, Assigned: mkmelin)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/112.0.0.0 Safari/537.36 Edg/112.0.1722.68

Steps to reproduce:

Dragging message from Search Messages dialogue to desktop doesn't work.

Error console shows:
Uncaught ReferenceError: messageFlavorDataProvider is not defined
ThreadPaneOnDragStart chrome://messenger/content/threadPane.js:158
ondragstart chrome://messenger/content/SearchDialog.xhtml:1

Apparently treadPane.js is being deprecated, see bug 1455429 comment #13.

Also see bug 1824317. It's unclear which search is affected there.

Keywords: regression
Whiteboard: [Supernova3p]

Thank you for reporting this. Not easy to work around afasics, so for affected users of Advanced Search, this can be a deal breaker.

STR

  1. Edit > Find > Search messages (Ctrl+Shift+F)
  2. From Advanced "Search Messages" dialog, drag a message to a file folder, e.g. Desktop.

Actual

Expected

  • find .eml file in the folder, e.g. Desktop
Blocks: tb-new-3pane
Severity: -- → S2
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
See Also: → 1824317
Summary: Dragging message from Search Messages dialogue to desktop doesn't work → Dragging message from advanced `Search Messages` dialogue to desktop doesn't work
Whiteboard: [Supernova3p] → [Supernova3p]
See Also: → 1827685
Assignee: nobody → mkmelin+mozilla
Blocks: 1827685

The cause of the non-working dragndrop was a missing include in SearchDialog.js, in combination with wanting a global messenger that doesn't exist in the given place.
I cleaned up the linting rules to avoid including mailWindow.js where not needed - due to the recursive nature of import-globals-from it many times hid a lot of bugs that should have been obvious otherwise. Mostly this is moving code around to where it's actually used, and inlining some onelines.

Attachment #9331737 - Attachment description: Bug 1831224 - Rework mailWindow.js lint inclusions and fix dragging message from advanced `Search Messages` dialogue to desktop. r=#thunderbird-reviewers → Bug 1831224 - Rework mailWindow.js lint inclusions and fix dragging message from advanced `Search Messages` dialogue to desktop. r=leftmostcat
Status: NEW → ASSIGNED
Target Milestone: --- → 115 Branch

Pushed by alessandro@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/5d6d14c2f8db
Rework mailWindow.js lint inclusions and fix dragging message from advanced Search Messages dialogue to desktop. r=leftmostcat

Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED

Thanks!

Status: RESOLVED → VERIFIED

Comment on attachment 9331737 [details]
Bug 1831224 - Rework mailWindow.js lint inclusions and fix dragging message from advanced Search Messages dialogue to desktop. r=leftmostcat

[Triage Comment]
Approved for beta

Attachment #9331737 - Flags: approval-comm-beta+
Regressions: 1833764
You need to log in before you can comment on or make changes to this bug.