Closed Bug 1833145 Opened 1 year ago Closed 1 year ago

"Unified" view no longer shows non-special, additional account folders

Categories

(Thunderbird :: Folder and Message Lists, defect, P2)

Thunderbird 115

Tracking

(thunderbird_esr102 unaffected, thunderbird114 fixed)

VERIFIED FIXED
115 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird114 --- fixed

People

(Reporter: denschub, Assigned: darktrojan)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

Attachments

(2 files)

Pre-115, I defaulted to the "unified" view. My use-case was to get a summarized view of all inboxes and all spam-folders, but still have access to the individual account folders. Both factors are important: I stay on top of all emails in my inbox, regardless of the account, but I also need to drag-and-drop emails into specific folders, and some folders automatically see new unread email based on server-side rules.

As you can see in the screenshot I attached, pre-115 shows the unified grouped folders on top, but then shows a list of other per-account folders below. In 115, this is gone: "unified" now only shows the grouped folders, and nothing else. I can somewhat mitigate this by enabling both "unified" and "all", but as seen in the screenshot, this re-lists the "grouped folders" again, and thus moving a few folders that also receive new mail barely out of view. That's a bit inconvenient for me. :)

Ideally for me, the unified view would continue showing per-account folders as pre-115 did.


I originally left a comment here, but that bug apparently was unrelated, so I figured it's worth filing. I'm tagging this as regression to increase the likelihood of someone looking at it, but if this is by design, please feel free to just close this as such. :)

Thanks Dennis, your screenshots make this very clear.
Confirming for Daily 115.0a1 (2023-05-15) (64-bit), Win10.

Any top-level folders which are not underneath default folders like Inbox etc. won't be accessible any more from unified Folder's view (this bug). Such folders were available from dedicated account top-level nodes in Unified Folders of 102. Which as reporter describes has some usability advantages, e.g. having all of your custom folders available from Unified Folders in a much more compact way (see screenshot, first vs. last image).

Alex, can you comment if access to other account folders have been removed from Unified Folders by design (and if yes, in which bug)?

The nice thing about the reduced Unified Folders in Supernova is less clutter at top level. Maybe we could combine the best of both worlds and add a single top-level "Other accounts and folders" top-level node to Unified Folders, where all of the "other" accounts and per-account "loose" folders can be tucked away nicely when not needed, but would still be available when needed.

Severity: -- → S3
Flags: needinfo?(alessandro)
Whiteboard: [Supernova3p]

We were trying to find a solution to collect and organize "orphan" folders that don't belong to any "primary" folder (inbox, sent, etc) but I think for now it's better to bring back the layout as it was before.

Flags: needinfo?(alessandro)

I'll deal with this.

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Priority: -- → P2
Summary: "Unified" view no longer shows additional account folders → "Unified" view no longer shows non-special, additional account folders
Target Milestone: --- → 115 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/47ce5f75be42
Include ordinary top-level folders in the Unified Folders mode. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

It now does exactly what I want it to do. Thank you. <3

Status: RESOLVED → VERIFIED
Attachment #9334914 - Flags: approval-comm-beta?

Comment on attachment 9334914 [details]
Bug 1833145 - Include ordinary top-level folders in the Unified Folders mode. r=aleca

[Triage Comment]
Approved for beta

Attachment #9334914 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: