Closed Bug 1819383 Opened 1 year ago Closed 1 year ago

subfolders of the inboxes aren't shown in the unified folders view

Categories

(Thunderbird :: Folder and Message Lists, defect, P1)

Thunderbird 111

Tracking

(thunderbird_esr102 unaffected, thunderbird111 wontfix, thunderbird112 fixed)

RESOLVED FIXED
113 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird111 --- wontfix
thunderbird112 --- fixed

People

(Reporter: musiquegraeme, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: regression, Whiteboard: [Supernova3p][fixed in bug 1822239])

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/110.0

Steps to reproduce:

I opened the new Thunderbird

Actual results:

I can't see any of the emails that are in my IMAP account online NOR am I able to subscribe to them again. THey have disappeared since I opened TB last time!

I discovered more - the problem was that I had folders set on Unified. When I switched Unified off I found all the folders under the account. But there seems no point to have unified as an option if it doesn't include all the folders unified.. and if I have all and Unified together then a lot of stuff is in twice.

Expected results:

I should have NOT lost all the folders that were subscribed to when I last opened TB, there seems to be a need for more thought in how Unified Folders works to unify all folders and not just a small subset... There used to be Local folders that was where these folders went as I recall.

I'm not sure what you're describing. IMAP folders can never be under Local Folders.
A screenshot may help.

Summary: I have lost all my folders that I've subscribed to! → I have lost all my folders that I've subscribed to! Folders set on Unified. Used to be in Local folders which doesn't show
Attached image Thunderbird folders.png

This is a combined screen shot. On the left you see the folders that show up if I set view to Unified, as it has been for a long time. This screenshot is in the new layout as you can tell. I can't give you a screenshot as it was - I've updated.....

On the right you see the folders that are viewable with All Folders. All the folders under O365 inbox weren't locatable with the new Unified View - they have always been locatable before, my view has been Unified for a long time. It was this change that made me think, and may well make other users think that Thunderbird has lost all their filed emails - I can imagine users leaving Thunderbird because of this.
Is this clear now?

Oh I see, subfolders of your inboxes aren't shown in the unified view.
(Still no idea why Local Folder isn't showing at all in the All view)

I agree subfolders should be shown, but creating a subfolder for my inbox, I don't see subfolders in Unified in 102 either.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: I have lost all my folders that I've subscribed to! Folders set on Unified. Used to be in Local folders which doesn't show → subfolders of your inboxes aren't shown in the unified folders view
Duplicate of this bug: 1819607

(In reply to Magnus Melin [:mkmelin] from comment #3)

(Still no idea why Local Folder isn't showing at all in the All view)

It might be the last folder, Minimail. It's possible to rename Local Folders in Account Settings.

I've filed this 14 years ago against POP as bug 516367. IMAP might be a bit more tricky technically.

See Also: → 516367

Looking at the Settings I think that it correct that MiniMail is in fact Local Folders

Every thing was okay with TB 110b4 and turn like this after TB111b1 update.

Steps to reproduce:

  1. Update TB 110b4 to 111b1
  2. Menu View > Folders > All

Actual results:
Step 1 :

  1. Inbox sub folders are not shown anymore
  2. Draft, Sent & Junk are shown just for 1 of my two accounts
  3. Local Folders just shown for Trash folder

Step 2:

  1. Inbox sub folders are visible in the ALL section only
  2. Sent is still not shown for Gmail account in ALL & Unified sections
  3. Junk are visible in the ALL section only
  4. Local Folders Trash, Outbox folders shown in the ALL section only ; Draft shown in the ALL section only, but considered as normal folder

I would like to triage, but don't have the right:
Tracking: thunderbird_esr102 & thunderbird110 unaffected ; 111 & 112 affected
Blocks: 1811366
Keywords: regression
Whiteboard: [Supernova] (as the bug is visible in the UI ;-))

Summary: subfolders of your inboxes aren't shown in the unified folders view → subfolders of the inboxes aren't shown in the unified folders view

question - are the messages of these subfolder shown when the combined/root unified folder is selected?

If they are not, then this is P1 priority.
If they are shown, then we can get set this as P2 or P3.

Severity: -- → S3
Flags: needinfo?(musiquegraeme)
Flags: needinfo?(mozilla.nicolasweb)
Priority: -- → P3

Messages are not shown anywhere in the folder pane tree, nor in Message list.
Quick filter dot not revel them.
However, Searching show them as search result (and so not visually in folders).

BTW, enabling again Unified folders make TB app hang for a looong time. That wasn't the case with just ALL folders view. Reported as bug 1821617

Flags: needinfo?(musiquegraeme)
Flags: needinfo?(mozilla.nicolasweb)
Priority: P3 → P1
See Also: → 1821617
See Also: → 1821623
See Also: → 1821852

Do we have an idea what this might be/related to?

It feels to me like this must be related so some other folder issue - can't put my finger on it.

Flags: needinfo?(geoff)
Blocks: 1821623
See Also: 1821623

I fixed the unified view in bug 1822239. It should show subfolders now.

Flags: needinfo?(geoff)

(In reply to Geoff Lankow (:darktrojan) from comment #12)

I fixed the unified view in bug 1822239. It should show subfolders now.

Super. Then tomorrow this bug should be fixed in 112.0b3, unless something blocks us from taking bug 1822239 to beta.

Depends on: 1822239

musiquegraeme, please give us an update on your situation after 112.0b3 becomes available for you.

Flags: needinfo?(musiquegraeme)

Will do :)

Flags: needinfo?(musiquegraeme)

(In reply to Wayne Mery (:wsmwk) from comment #14)

musiquegraeme, please give us an update on your situation after 112.0b3 becomes available for you.

Flags: needinfo?(musiquegraeme)

Yes, I hadn't realised that it had come! And it is now working. Praise the Lord!

Flags: needinfo?(musiquegraeme)
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Whiteboard: [Supernova] → [fixed in bug 1822239][Supernova]
Target Milestone: --- → 113 Branch
Whiteboard: [fixed in bug 1822239][Supernova] → [Supernova3p][fixed in bug 1822239]

This has now completely changed again and doesn't show correctly in Unified view. It changed last update and is no better in this new update - I'm now on 114.0b3

Please file a new bug, this one closed two months ago. If you upload the file virtualFolders.dat from your profile directory, that may help diagnose the problem.

Depends on: 1833145
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: