Closed Bug 1840123 Opened 1 year ago Closed 3 months ago

Windows System Notifications are unresponsive.

Categories

(Thunderbird :: General, defect)

Thunderbird 115
Unspecified
Windows
defect

Tracking

(thunderbird_esr115 affected, thunderbird118 unaffected)

RESOLVED DUPLICATE of bug 1893349
Tracking Status
thunderbird_esr115 --- affected
thunderbird118 --- unaffected

People

(Reporter: johnlangone, Unassigned)

References

Details

(Keywords: dupeme)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/114.0.0.0 Safari/537.36

Steps to reproduce:

Settings -> General -> Incoming Mails -> Show an Alert -> Use the system notification

Actual results:

Notifications are shown but clicking on notifications don't do anything.

Expected results:

Clicking a notification should at the very least open & focus Thunderbird.

Other behavior would be to open to related message in inbox, etc.

More advanced would be to implement intelligent clearing of notifications based off the message that is viewed or update / clear accordingly.

Component: Untriaged → General
OS: Unspecified → Windows
See Also: → 1840092

I noticed that clicking the notification will restore a minimized window, but it will not bring it to the front and in focus, which I believe would be expected.

Doug can you reproduce this?

Flags: needinfo?(dmccammishjr)

So far, I'm having a different problem. The notification appears for about 5 seconds when I have it set to appear for 25+ seconds. I have not been consistently quick enough to click on the notification to see what happens. I will continue testing. (Win 11 64, TBird 115.2.2 I haven't tested 118.x for this yet.)

Flags: needinfo?(dmccammishjr)

TBird 118.0b5 with patches. Win 11 64 EN-us Got a new mail notification (TBird minimized), clicked on it, TBird opened and mail was there. Alert was up 35 seconds per my setting. Seems to be working correctly as of last build.

Here is a screen recording of the behavior I am experiencing.

https://youtu.be/PmmjX1DkT2I

  • Clicking notification will restore window from being minimized, but it is behind other windows open.

Would be nice if while messages are marked read, their notifications are cleared.

I'm also experiencing this issue.

Thunderbird version: 115.3.1
Windows version: Microsoft Windows 10 Enterprise 10.0.19044 Build 19044

Unfortunately, due to an Organizational Policy I am not able to update Thunderbird and check if it has been fixed.

Current behavior:

When receiving a Windows notification and clicking on it, the notification disappears but Thunderbird does NOT open and show the E-mail in question. Nothing happens.

Expected behavior:

When receiving a Windows notification and clicking on it, Thunderbird opens and shows the E-mail in question.

N.B.: One slight difference is that for John Thunderbird opens when clicking on the notification, for me it just disappears and nothing happens. Thunderbird remains minimized.

Problem still exists in 120b1

I am experiencing the same issue with TB 115.4.1 (latest version of W10 Pro 22H2) and this is also discussed on Reddit:
https://www.reddit.com/r/Thunderbird/comments/14ya0fa/notifications_broken_in_115/

The problem persists on 115.4.1 in Windows 11

See Also: → 1858603

Pref alerts.useSystemBackend is already false in 115. Set alerts.useSystemBackend.windows.notificationserver.enabled to false as well, that should improve things.

Windows system notifications have been restored in Betterbird 115.
Great Job! :-)

(In reply to doelli from comment #11)

Windows system notifications have been restored in Betterbird 115.
Great Job! :-)

https://www.betterbird.eu/releasenotes/?locale=de&version=102.15.1&channel=default&os=WINNT&buildid=20230913221212

(In reply to doelli from comment #12)

(In reply to doelli from comment #11)

Windows system notifications have been restored in Betterbird 115.
Great Job! :-)

The previous link was unfortunately incorrect.
Here is the correct one: https://www.betterbird.eu/releasenotes/

Is there any updates on this? I still have the issue on 115.8.0.
Clicking the windows system notification just dismisses the notification but does not open up thunderbird.

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Duplicate of bug: 1893349
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.