voyages-sncf.com - reservation form doesn't work, validation script fails

RESOLVED FIXED

Status

P1
major
RESOLVED FIXED
16 years ago
4 years ago

People

(Reporter: wolruf, Unassigned)

Tracking

Details

(Whiteboard: [syntax-js][bug248549notfixed], URL)

Attachments

(1 attachment)

(Reporter)

Comment 1

16 years ago
it works fine if you select 'Réservation' on home page instead of 'time table
only', they could at least show a warning instead of a 'no action'... oh well.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 2

16 years ago
Two other reports of this bug.
Status: RESOLVED → REOPENED
Priority: -- → P2
Resolution: INVALID → ---

Comment 3

16 years ago
*** Bug 188862 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
*** Bug 189999 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
Works for me in Moz 20030306 OSX. Reporters, please retest.
Severity: normal → major
Summary: voyages-sncf.com - Form validation doesn't work → voyages-sncf.com - reservation form doesn't work, validation script fails

Comment 6

16 years ago
Two javascript errors on the main page voyages.sncf.com (one from doubleclick.net)
Two more javascripts errors on the "Commande d'un voyage" page (PASSENTR0 and
PASSENTR1, as previously)
But now it works, I can buy a ticket.
Tested with 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020925 Debian/1.1-1

Comment 7

16 years ago
Unfortunatley it's still broken here both with moz 1.3 and 1.4a / RH linux

Error: PASSENTR0 is not defined
Source File:
http://www.voyages-sncf.com/dynamic/_SvTermCommvoy1CcTa?_TMS=1050305789736&_DLG=SvTermCommvoy1CcTa&_LANG=FR&_AGENCY=VSC&weblogic.httpd.user=nmailhot&regularTravel=86098&_TMS=1050305789439
Line: 634

I have an account of this site (ie it stores most frequent queries and bought
tickets) and I've not been able to use it till last fall.

konqueror however is ok, evn if switching browsers like this plain sucks.

Comment 8

16 years ago
Created attachment 122288 [details]
Screenshots of how it is displyed in IE and how it diplays in Mozilla

The search form doesn't display properly + a click on the green "valider"
button doesn't do anything.

Comment 9

16 years ago
Just to signal the same bug under PC/Windows2000.

Updated

16 years ago
OS: Linux → All
Hardware: PC → All

Comment 10

16 years ago
The problem exist for me on Mozilla 1.{3,4a,4b} on Win2K/debian sid/Aix 4.3.3.

(Reporter)

Comment 11

16 years ago
raising severity, site is just not usable anymore, main page form doesn't work
at all (not just the calendar), but also submit button.

JavaScript console shows:
Error: event is not defined
Source File:
http://www.voyages-sncf.com/dynamic/_SvHomePage?_TMS=1054068497100&_DLG=SvHomePage&_LANG=FR&_AGENCY=VSC&WebGLSession=PtPPEeXqloxvlSsmxfZ1DgeGc20nOMUj7HlTdQLQSm20FkwhhB2m|-3790654422305252045/170395459/6/7251/7251/50443/50443/7251/-1
Line: 882
Error: cW has no properties
Source File:
http://www.voyages-sncf.com/dynamic/_SvHomePage?_TMS=1054068497100&_DLG=SvHomePage&_LANG=FR&_AGENCY=VSC&WebGLSession=PtPPEeXqloxvlSsmxfZ1DgeGc20nOMUj7HlTdQLQSm20FkwhhB2m|-3790654422305252045/170395459/6/7251/7251/50443/50443/7251/-1
Line: 886

Given this is a public company site, one of the biggest e-commerce sites in
France, great visibility, increasing priority to P1.

Sent e-mail again via http://www.voyages-sncf.com/dynamic/faq.mail
Keywords: evang500
Priority: P2 → P1
Whiteboard: [syntax-js]

Comment 13

16 years ago
Still nok with moz 1.4rc1 linux/Red Hat

(mozilla-1.4-1 rpm from Red Hat Raw Hide devel distro)
(Reporter)

Comment 14

16 years ago
*** Bug 208610 has been marked as a duplicate of this bug. ***
*** Bug 209350 has been marked as a duplicate of this bug. ***
-> french.
Assignee: nitot → french
Status: REOPENED → NEW
Component: Europe: West → French
QA Contact: brantgurganus2001 → french

Comment 17

16 years ago
To see the bottom part of the form please look at bug 209350.


As a workaround, you can click at the blue tab "Trains" (or another one) to make
a reservation. Only the main page has a problem, other pages (where you can also
do the reservation) work fine.

Comment 18

16 years ago
other pages do *not* work fine.
"trains" is as broken as the main page if one uses a saved query (ie get an
account, save a trip in "preferred trips" and try to use it in trains -> it fails)

Comment 19

16 years ago
*** Bug 211117 has been marked as a duplicate of this bug. ***
Is it still a problem ? according to #18, I need an account to check the
problem. is there something else ?

Comment 21

15 years ago
I think it's been fixed but there may well be some bugs lurking in places still.

Since it's a major site, it should be checked every major moz release for
regressions IMHO
(Reporter)

Comment 22

15 years ago
still broken, try clicking on the calendar to pickup a different date
(showcalendar), no popup shows up (eventhough in later steps, this very same
calendar works fine...).

Updated

14 years ago
Whiteboard: [syntax-js] → [syntax-js][bug248549notfixed]

Comment 23

14 years ago
Definitely not working for me.

I go to  http://www.sncf.com/ and click 'Réservez ou achetez' bringing me to
http://www.voyages-sncf.com/dynamic/_SvHomePage?_TMS=1096118661064&_DLG=SvHomePage&_LANG=FR&_AGENCY=VSC

Clicking on the calendar popup icons doesnt result in the calendar appearing and
gives the following errors:

Error: event is not defined
Source File:
http://www.voyages-sncf.com/dynamic/_SvHomePage?_TMS=1096118661064&_DLG=SvHomePage&_LANG=FR&_AGENCY=VSC
Line: 696
Error: cW has no properties
Source File:
http://www.voyages-sncf.com/dynamic/_SvHomePage?_TMS=1096118661064&_DLG=SvHomePage&_LANG=FR&_AGENCY=VSC
Line: 700

However, manually typing in the date and hitting 'recherche' starts teh search
and then I get an error:
Une erreur technique est survenue. Nous vous prions de bien vouloir nous en excuser.

This sounds like it might be a server side problem


Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

Comment 24

14 years ago
Feedback page is: http://www.voyages-sncf.com/dynamic/faq.mail?_LANG=FR&type_mail=1

Sent the following badly written letter!

bonjour -

J'ai essayer de reserver un train chez votre site et j'ai eu des problems. 

D'abord, quand je essayer de entre un date sur la page de reservations
(http://www.voyages-sncf.com/dynamic/_SvHomePage?_TMS=1096119489821&_DLG=SvHomePage&_LANG=FR&_AGENCY=VSC)
le calendrier ne lance pas. Je vois des erreurs de Javascript suivant:

Error: event is not defined
Source File:
http://www.voyages-sncf.com/dynamic/_SvHomePage?_TMS=1096118661064&_DLG=SvHomePage&_LANG=FR&_AGENCY=VSC
Line: 696
Error: cW has no properties
Source File:
http://www.voyages-sncf.com/dynamic/_SvHomePage?_TMS=1096118661064&_DLG=SvHomePage&_LANG=FR&_AGENCY=VSC
Line: 700

ensuite, apres que j'ai entre le date a main et cliquer 'recherche', j'ai l'erreur:

Une erreur technique est survenue. Nous vous prions de bien vouloir nous en excuser.

SVP aider moi trouver un biullet pour que je puisse visiter ma mere le noel!

Excuse mon francise tres mauvais!

merci

dave

Comment 25

14 years ago
Just retried in IE. The 'Une erreur technique est survenue. Nous vous prions de
bien vouloir nous en excuser' error still appears. Looks like its a temp server
side issue. That just leaves the pop-up calendar not working

Comment 26

14 years ago
Still the same problem : javascript calendar doesn't show up.

[First error on page load]
Error: NavigDetail[2] has no properties
Source File: http://www.voyages-sncf.com/homepage/site_under/site_under_vsc.js
Line: 25

[Errors as soon as you click on the calendar img]
Error: event is not defined
Source File:
http://www.voyages-sncf.com/dynamic/_SvHomePage?_TMS=1101822487212&_DLG=SvHomePage&_LANG=FR&_AGENCY=VSC
Line: 696

Error: cW has no properties
Source File:
http://www.voyages-sncf.com/dynamic/_SvHomePage?_TMS=1101822487212&_DLG=SvHomePage&_LANG=FR&_AGENCY=VSC
Line: 700


It's strange, but it seems I read here a few months ago, that the calendar used
to work. Would it be true?

Comment 27

14 years ago
They seem not to test with Gecko and have a continuous break/fix/rebreak cycle

Comment 28

13 years ago
This bug should be closed now.
(Reporter)

Comment 29

13 years ago
Site was redesigned, even showing strict doctype.
Status: NEW → RESOLVED
Last Resolved: 16 years ago13 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.