Closed Bug 1844771 Opened 1 year ago Closed 10 months ago

'Remove from History' menu item/command doesn't work on Adaptive History results

Categories

(Firefox :: Address Bar, defect, P2)

defect

Tracking

()

RESOLVED FIXED
119 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox-esr115 --- wontfix
firefox115 --- wontfix
firefox116 --- wontfix
firefox117 --- wontfix
firefox118 --- wontfix
firefox119 --- fixed

People

(Reporter: aryx, Assigned: mak)

References

Details

(Keywords: privacy, Whiteboard: [sng-scrubbed][search-privacy])

Attachments

(1 file)

Firefox 115.0.2 and latest 117.0a1

Reproduces in one profile but not in another:

  1. In the url bar: type something and a history item gets suggested.
  2. Use the "..." menu item for the suggested url.
  3. Use 'Remove from history'.

Actual result:
Suggestion persists.

Expected result:
Suggestion removed, replace with another one if available.

Inspecting the menu fails with devtools, the inspector focuses on the suggested url bar rows.

The removal succeeded once directly after startup but this scenario did not work repeatedly.

There are no extensions installed in this profile.

Could you try searching for the URL in the history sidebar to see if it appears there?

Could you also do a Places database integrity check? (Please go to about:support to do this.) Then please try to reproduce your bug again.

Flags: needinfo?(aryx.bugmail)

After the Places db integrity got checked.

> Task: checkIntegrity
+ The places.sqlite database is sane
+ The favicons.sqlite database is sane
> Task: invalidateCaches
+ The caches have been invalidated
> Task: checkCoherence
+ The database is coherent
> Task: expire
+ Database cleaned up
> Task: originFrecencyStats
+ Recalculated origin frecency stats
> Task: vacuum
+ Initial database size is 76800KiB
+ The database has been vacuumed

In the history sidebar, https://www.facebook.com/<page_name> is found. The address bar suggests it if the start of the group name gets typed but the "..." > "Remove from History" command removes it neither from the address bar suggestion nor from the history sidebar.

Flags: needinfo?(aryx.bugmail)

Reproduces here as well. Yes, the entry is in the history sidebar. (And yes, I ran the integrity check.)

Hey Adrian, would you be able to try reproducing the steps for this bug? It would be quite helpful for us. Thank you.

Severity: -- → S3
Flags: needinfo?(aflorinescu)
Priority: -- → P2
Whiteboard: [sng-scrubbed][search-privacy]

Tried reproducing on 118.0a1 20230801034557 with clean profile, creating random history entries, with no luck so far.

On my personal profile though, hit a suggest entry that would reflect the described behavior, regardless how many removals I'd make. However, while looking into console/DB to see if I spot anything interesting, at some point the suggestion removal worked and subsequently couldn't catch it again.

I'd guess that it needs certain conditions to reproduce, but I'm at a loss how to debug once I've caught it. James, anything that might add some additional value while reproducing it, given that we can't find a clear STR to do it atm?

Flags: needinfo?(aflorinescu) → needinfo?(jteow)

I was able to capture this in the debugger, the reason this doesn't work is because the result is not returned by the Places provider, but it's returned by the InputHistory provider... and the InputHistory provider is not handling the command. So the menuitem is a no-op.

Summary: 'Remove from History' menu item/command almost never works in one profile → 'Remove from History' menu item/command doesn't work on Adaptive History results
Flags: needinfo?(jteow)

These should be more or less the steps to reproduce:

  1. open new tab, visit youtube.com, close the tab
  2. open new tab, type "tube" in the address bar, pick the youtube.com result
  3. type "tube" in the address bar, try to remove the youtube.com result

That result is provided by https://searchfox.org/mozilla-central/source/browser/components/urlbar/UrlbarProviderInputHistory.sys.mjs and that provider doesn't handle onEngagement.
We add the result menu to result.source == lazy.UrlbarUtils.RESULT_SOURCE.HISTORY, that makes sense because disabling for input history would be confusing.
Long term it would be better if we'd just ask each provider/result for isBlockable and helpUrl, rather than this kind of allowance for any HISTORY result.

Keywords: steps-wanted
Duplicate of this bug: 1849395
Duplicate of this bug: 1851628
Assignee: nobody → mak
Status: NEW → ASSIGNED
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/3023de337294
Address Bar 'Remove from History' option doesn't work on Adaptive History results. r=jteow
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 119 Branch

Since nightly and release are affected, beta will likely be affected too.
For more information, please visit BugBot documentation.

Duplicate of this bug: 1854780
Duplicate of this bug: 1833304
Duplicate of this bug: 1857689
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: