Closed Bug 1848261 Opened 10 months ago Closed 9 months ago

Event dialog with many invitees expands beyond screen height

Categories

(Calendar :: Dialogs, defect)

Thunderbird 115
defect

Tracking

(thunderbird_esr115 fixed, thunderbird118 fixed)

RESOLVED FIXED
119 Branch
Tracking Status
thunderbird_esr115 --- fixed
thunderbird118 --- fixed

People

(Reporter: sb, Assigned: mkmelin)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/116.0

Steps to reproduce:

Open an event to which many people are included as invitees.

Actual results:

The event dialog open and expands to show all the invitees with the top of the dialog overflowing the top of the screen and the bottom of the dialog overflowing the bottom (or at minimum is tucked in behind the windows taskbar on windows 10).

The right side scroll bar is not showing suggesting the window has opened at a height to fit all the invitees into the box.

The dialog close button is therefore not available.

If you then grab the side of the dialog and expand it by mouse the dialog will redraw with the top heading aligned to fit on the screen and the description disappearing off the bottom of the screen.

Expected results:

The event dialog should fit entirely on the screen with a scroll bar on the right of the invitees box.

Thunderbird 115.1.0 (problem replicates in troubleshoot mode with add-ons disabled)

Attached file manyattendees.ics

Sample event to reproduce the issue.

Assignee: nobody → mkmelin+mozilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Blocks: 1821304
Attachment #9349360 - Attachment description: Bug 1848261 - Event dialog with many invitees expands beyond screen height. r=#thunderbird-front-end-reviewers → Bug 1848261 - Event dialog with many invitees expands beyond screen height. r=aleca
Target Milestone: --- → 119 Branch

Pushed by kaie@kuix.de:
https://hg.mozilla.org/comm-central/rev/144ba5ff17ef
Event dialog with many invitees expands beyond screen height. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED

Comment on attachment 9349360 [details]
Bug 1848261 - Event dialog with many invitees expands beyond screen height. r=aleca

[Approval Request Comment]
Regression caused by (bug #): modern flexbox
User impact if declined: with many invitees, bad UI
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): safe fix

Attachment #9349360 - Flags: approval-comm-esr115?
Attachment #9349360 - Flags: approval-comm-beta?

Comment on attachment 9349360 [details]
Bug 1848261 - Event dialog with many invitees expands beyond screen height. r=aleca

[Triage Comment]
Approved for beta

Attachment #9349360 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9349360 [details]
Bug 1848261 - Event dialog with many invitees expands beyond screen height. r=aleca

[Triage Comment]
Approved for esr115

Attachment #9349360 - Flags: approval-comm-esr115? → approval-comm-esr115+
Duplicate of this bug: 1845774
Duplicate of this bug: 1853633
Duplicate of this bug: 1853915
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: