Closed Bug 1850266 Opened 8 months ago Closed 3 months ago

When toggling the Quick Filter button off and on, persisted settings should be remembered

Categories

(Thunderbird :: Folder and Message Lists, defect, P1)

Thunderbird 115

Tracking

(Accessibility Severity:s2, thunderbird_esr115 fixed)

RESOLVED FIXED
123 Branch
Accessibility Severity s2
Tracking Status
thunderbird_esr115 --- fixed

People

(Reporter: elijmitchell, Assigned: elijmitchell)

References

(Blocks 3 open bugs)

Details

Attachments

(1 file)

When the Quick Filter bar is turned off, the sticky value is not retained (keep filters applied when switching folders). Additionally, top-level filters in bug 1849249 are also not remembered. These settings should be remembered.

Severity: -- → S3
Version: unspecified → Thunderbird 115
Blocks: 1851841
  • Remember persisted settings when quick filter is toggled off/on.

Depends on D186888

Priority: -- → P2
See Also: → 1847265
Attachment #9351830 - Attachment description: Bug 1850266 - Remember persisted filters when toggling quick filter. r=#thunderbird-front-end-reviewers → WIP: Bug 1850266 - Remember persisted filters when toggling quick filter. r=#thunderbird-front-end-reviewers

Will this land in the next point release?
It's a pretty annoying regression.

(In reply to klk745 from comment #2)

Will this land in the next point release?
It's a pretty annoying regression.

No, it will not land in the next point release, but I will be pushing out a patch for this this week and then we will see when it gets uplifted.


Priority has been raised on this as this is an accessibility issue. Keyboard navigation is severely hindered/cumbersome when Quick Filter is open. However, when Quick Filter is closed, settings are lost.

Severity: S3 → S2
Accessibility Severity: --- → s2
Priority: P2 → P1
Attachment #9351830 - Attachment description: WIP: Bug 1850266 - Remember persisted filters when toggling quick filter. r=#thunderbird-front-end-reviewers → WIP: Bug 1850266 - Remember persisted filters when toggling quick filter.
Attachment #9351830 - Attachment description: WIP: Bug 1850266 - Remember persisted filters when toggling quick filter. → Bug 1850266 - Remember persisted filters when toggling Quick Filter. r=#thunderbird-front-end-reviewers
Blocks: 1864493
Attachment #9351830 - Attachment description: Bug 1850266 - Remember persisted filters when toggling Quick Filter. r=#thunderbird-front-end-reviewers → WIP: Bug 1850266 - Remember persisted filters when toggling Quick Filter. r=#thunderbird-front-end-reviewers
Attachment #9351830 - Attachment description: WIP: Bug 1850266 - Remember persisted filters when toggling Quick Filter. r=#thunderbird-front-end-reviewers → Bug 1850266 - Remember persisted filters when toggling Quick Filter. r=#thunderbird-front-end-reviewers

Comment on attachment 9351830 [details]
Bug 1850266 - Remember persisted filters when toggling Quick Filter. r=#thunderbird-front-end-reviewers

Revision D187567 was moved to bug 1850265. Setting attachment 9351830 [details] to obsolete.

Attachment #9351830 - Attachment is obsolete: true
Attachment #9351830 - Attachment is obsolete: false
Target Milestone: --- → 122 Branch
Target Milestone: 122 Branch → 123 Branch

Pushed by john@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/cbd39e8f53fa
Remember persisted filters when toggling Quick Filter. r=aleca, sol

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED

Comment on attachment 9351830 [details]
Bug 1850266 - Remember persisted filters when toggling Quick Filter. r=#thunderbird-front-end-reviewers

[Approval Request Comment]
Regression caused by (bug #): Changes between 102 and 115
User impact if declined: Significant. Settings that should be persisted removed when turning Quick Filter on and off. This fixes this. Additionally, this makes navigating the message list more accessible with keyboard navigation because the user can close the Quick Filter when it is not needed.
Testing completed (on c-c, etc.): Yes, try runs and this has been on c-c.
Risk to taking this patch (and alternatives if risky): Low risk.

For comm-beta, the 123 daily to 123 beta change is coming soon, so this should be automatically uplifted into the beta during that change.

Attachment #9351830 - Flags: approval-comm-esr115?
Attachment #9351830 - Flags: approval-comm-beta?

Comment on attachment 9351830 [details]
Bug 1850266 - Remember persisted filters when toggling Quick Filter. r=#thunderbird-front-end-reviewers

This is on beta since the merge.

Attachment #9351830 - Flags: approval-comm-beta?

Comment on attachment 9351830 [details]
Bug 1850266 - Remember persisted filters when toggling Quick Filter. r=#thunderbird-front-end-reviewers

[Triage Comment]
Approved for esr115

Attachment #9351830 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: