Closed Bug 1850828 Opened 11 months ago Closed 10 months ago

When link is clicked in an external app, firefox 117 does not open the link if it needs to start

Categories

(Firefox :: General, defect)

Firefox 117
defect

Tracking

()

VERIFIED FIXED
119 Branch
Tracking Status
relnote-firefox --- 117+
firefox-esr102 --- unaffected
firefox-esr115 --- unaffected
firefox117 + verified
firefox118 + verified
firefox119 + verified

People

(Reporter: scottha, Assigned: dao)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/117.0

Steps to reproduce:

Click on a link in Outlook for Mac, Mac Mail, Word (any external app)

Actual results:

Firefox opens to my home page and does NOT open the link which triggered the Firefox launch

Expected results:

Firefox opens to my home page and also opens the link which triggered the Firefox launch

The Bugbug bot thinks this bug should belong to the 'Core::Widget: Cocoa' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Widget: Cocoa
Product: Firefox → Core
See Also: → 1850848

pushlog: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=e4d87ff75575880ea0c0fa09b316e360e4d9492f&tochange=511a6a347d490d95f83e47414d604a17e143c218
good: https://archive.mozilla.org/pub/firefox/nightly/2023/07/2023-07-07-09-28-00-mozilla-central/
bad: https://archive.mozilla.org/pub/firefox/nightly/2023/07/2023-07-07-22-03-36-mozilla-central/

STR used:

  1. Get a .dmg Firefox build.
  2. Mount dmg.
  3. Drag and drop Firefox locally. (e.g Desktop).
  4. Launch Firefox and stop updates( or modify channel.prefs).
  5. Make Firefox the default browser.
  6. Close Firefox.
  7. Click on an external link : eg. a hyperlink featured in a slack channel.

Please note that if Firefox is launched using Profile Manager the issue does not reproduce.

From that range, https://bugzilla.mozilla.org/show_bug.cgi?id=713713 seems like the most plausible candidate I'm seeing?

Flags: needinfo?(dao+bmo)

(In reply to Ryan VanderMeulen [:RyanVM] from comment #3)

From that range, https://bugzilla.mozilla.org/show_bug.cgi?id=713713 seems like the most plausible candidate I'm seeing?

Agreed. Will take a closer look.

Assignee: nobody → dao+bmo
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(dao+bmo)
Regressed by: 713713
Component: Widget: Cocoa → General
Product: Core → Firefox

Set release status flags based on info from the regressing bug 713713

(In reply to Ardelean Oana, Desktop QA from comment #2)

STR used:

  1. Get a .dmg Firefox build.
  2. Mount dmg.
  3. Launch Firefox and stop updates( or modify channel.prefs).
  4. Make Firefox the default browser.
  5. Close Firefox.
  6. Click on an external link : eg. a hyperlink featured in a slack channel.

Please note that if Firefox is launched using Profile Manager the issue does not reproduce.

@Ardelean, are you running Firefox out of the .dmg or copying it to somewhere before launching it?

Flags: needinfo?(oardelean)

I believe the cause of this issue is the same as the issue I describe in bug 1818194 comment 10, due to the symptoms and cause issue matching so closely.

[Tracking Requested - why for this release]:
Release regression with 117.

(In reply to Nika Layzell [:nika] (ni? for response) from comment #7)

I believe the cause of this issue is the same as the issue I describe in bug 1818194 comment 10, due to the symptoms and cause issue matching so closely.

Thanks! That makes sense, as I couldn't reproduce this bug via just ./obj-x86_64-pc-linux-gnu/dist/bin/firefox https://example.com
For the purpose of this bug, I guess I'll try your suggestion of using browsing-context-discarded instead of the unload handler in registerOpeningWindow.

After mounting, I copied Firefox by dragging it onto Desktop. Sorry for not being more explicit. Updating the steps.

Flags: needinfo?(oardelean)
See Also: → 1851276
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/baae9ed0f676
Use browsing-context-discarded instead of unload listener to delete pending windows that close before we track them as open windows. r=nika
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 119 Branch

Would be great if we could get some QA testing on this fix now that's available in Nightlies, including the See Also bugs.

Flags: qe-verify+

The patch landed in nightly and beta is affected.
:dao, is this bug important enough to require an uplift?

  • If yes, please nominate the patch for beta approval.
  • If no, please set status-firefox118 to wontfix.

For more information, please visit BugBot documentation.

Flags: needinfo?(dao+bmo)

Comment on attachment 9351603 [details]
Bug 1850828 - Use browsing-context-discarded instead of unload listener to delete pending windows that close before we track them as open windows. r=nika

Beta/Release Uplift Approval Request

  • User impact if declined: please see comment 0
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: please see comment 0
  • List of other uplifts needed: none
  • Risk to taking this patch: Medium
  • Why is the change risky/not risky? (and alternatives if risky): It's a relatively small and contained fix, but going with medium since unfortunately we don't have automated tests for the behavior that broke.
  • String changes made/needed: none
  • Is Android affected?: No
Flags: needinfo?(dao+bmo)
Attachment #9351603 - Flags: approval-mozilla-beta?

Comment on attachment 9351603 [details]
Bug 1850828 - Use browsing-context-discarded instead of unload listener to delete pending windows that close before we track them as open windows. r=nika

Approved for 118.0b6.

Attachment #9351603 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Verified as fixed on Firefox 118.0b6(build ID: 20230907180212) and Nightly 119.0a1(build ID: 20230908094535) on macOS 12.
Hyperlinks opened from a third-party application are now opened properly with Firefox.

Duplicate of this bug: 1851276
See Also: 1851276
Duplicate of this bug: 1850848
See Also: 1850848

Comment on attachment 9351603 [details]
Bug 1850828 - Use browsing-context-discarded instead of unload listener to delete pending windows that close before we track them as open windows. r=nika

Unfortunately, backing out the regressing change was causing test failures in browser_search_history.js. I'm going to re-land that and uplift this fix instead.

Attachment #9351603 - Flags: approval-mozilla-release+

Added to the 117.0.1 release notes:

Fixed a bug causing links opened from outside Firefox to not open on macOS

Verified as fixed on Firefox 117.0.1(build ID: 20230912013654) on macOS 12.
Hyperlinks from a third-party app, .webloc files and ‘open -a’ commands are successfully opened.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Duplicate of this bug: 1852410
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: