Closed Bug 1851940 Opened 9 months ago Closed 9 months ago

Enable addon suggestions by default with treatment B (no stars) for Suggest users

Categories

(Firefox :: Address Bar, task, P1)

task

Tracking

()

VERIFIED FIXED
119 Branch
Tracking Status
firefox118 --- verified
firefox119 --- verified

People

(Reporter: adw, Assigned: adw)

References

Details

Attachments

(1 file)

Treatment B (no stars) in the addon suggestion experiment was successful, so we'd like to enable that treatment by default for all Suggest users.

This enables addon suggestions by default (treatment B, no stars) for all
Suggest users. As discussed on Slack, I did not remove the related prefs and
Nimbus variables in case something goes wrong and we need to disable the feature
ASAP. In that case, we can ship a Nimbus rollout to re-disable it. After a
release cycle or two without any problems, we can do a follow-up that removes
them. I also left the treatment A implementation. We can remove that in a
follow-up too.

Since I did leave the prefs and variables, I only had to change their default
values to enable the feature with treatment B.

One problem is that addon suggestions should be best matches, but we don't want
to set bestMatch.enabled to true by default. To work around that, I set the
related best-match properties on the UrlbarResult inside AddonSuggestions
instead of delegating it to the quick suggest provider. Product has requested
that we remove the "Top pick" checkbox from about:preferences, and at that time
we should also remove the bestMatch.enabled pref. In the future, results
should be best matches on a case-by-case basis.

This makes a few UI changes that aren't strictly related but I wanted to fix
since more users will now see these suggestions:

  • Cache the "Firefox extension" group label to prevent pop-in.
  • Align the URL and row title by baseline. Right now the URL is too high above
    the title.
  • Set inline-margin-end of the icon so it's symmetrical with the starting
    margin/padding. The current value of 8px is hardcoded and too small.
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b1ae7ef456bc
Enable addon suggestions by default with treatment B (no stars) for all Suggest users. r=daisuke
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 119 Branch

STR for QA:

Firefox Suggest enabled

When Firefox Suggest is enabled, addon suggestions should also be enabled by default. So to test this, please enable Firefox Suggest as you normally do (browser.urlbar.quicksuggest.enabled = true) and type any addon keyword, for example:

clips
videos
how to download
grammar
spam
adblock

Firefox Suggest disabled

Addon suggestions should not be shown when Firefox Suggest is disabled, i.e. when browser.urlbar.quicksuggest.enabled = false. Firefox Suggest is only enabled for users in the U.S. (unless you set that pref in about:config), so outside the U.S. addon suggestions should not be shown.

Flags: qe-verify+
Flags: in-testsuite+

Comment on attachment 9351931 [details]
Bug 1851940 - Enable addon suggestions by default with treatment B (no stars) for all Suggest users.

Beta/Release Uplift Approval Request

  • User impact if declined: We'd like to ship this feature (addon suggestions in the urlbar) in 118.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Please see earlier comment
  • List of other uplifts needed: These 3 bugs need to be uplifted in the following order: bug 1851940 (this bug), bug 1851941, bug 1851942
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This bug turns on addon suggestions in the urlbar for all users in the U.S., so it may be considered medium or higher risk. However, this feature was previously validated with an experiment on 10% of the same user population (references below). The patch itself isn't very complicated, and the feature is well tested both by automated and QA coverage.
  • String changes made/needed:
  • Is Android affected?: No

References:

Attachment #9351931 - Flags: approval-mozilla-beta?

Comment on attachment 9351931 [details]
Bug 1851940 - Enable addon suggestions by default with treatment B (no stars) for all Suggest users.

Approved for 118.0b7, thanks.

Attachment #9351931 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Verified on Nightly 119.0a1 (2023-09-07) with details in 1852329#c1.

Verified as fixed with Firefox 118.0b7 on Windows 10, Mac 13, Ubuntu 22. Further smoke testing will be performed and reported in bug 1852329.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: