Closed Bug 1852732 Opened 11 months ago Closed 11 months ago

Context menu items in preferences have no hover background color

Categories

(Thunderbird :: Theme, defect)

Thunderbird 115
Desktop
Linux
defect

Tracking

(thunderbird_esr115 fixed, thunderbird118 fixed, thunderbird119 fixed)

RESOLVED FIXED
119 Branch
Tracking Status
thunderbird_esr115 --- fixed
thunderbird118 --- fixed
thunderbird119 --- fixed

People

(Reporter: freaktechnik, Assigned: freaktechnik)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image image.png

Regression range: https://hg.mozilla.org/comm-central/pushloghtml?fromchange=d0c328a2cc3340ab6f6458442ea89e366e33bd8e&tochange=6490fed4cf5c6d79aacd25442d7e6a14560c7878 (I suspect it's bug 1828413 )

And based on that bug I assume this affects Linux only.

The issue is caused by this rule: https://searchfox.org/comm-central/rev/621b473f53010d28dd3872693cd42f7a7a2dd61b/mail/themes/shared/mail/common.css#125

STR:

  • Open Settings
  • Go to privacy tab
  • Open passwords dialog (saved passwords)
  • Right click on any entry
  • Hover over any activated menu item
Summary: Context menu items in preferences have no background color → Context menu items in preferences have no hover background color
Assignee: nobody → martin
Status: NEW → ASSIGNED
Target Milestone: --- → 119 Branch

Pushed by benc@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/eaf52b27ea0a
Don't modify menu item background color. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED

Comment on attachment 9352645 [details]
Bug 1852732 - Don't modify menu item background color. r=#thunderbird-front-end-reviewers

[Approval Request Comment]
Regression caused by (bug #): probably bug 1828413
User impact if declined: Context menu items appear blank when hovered on some linux themes
Testing completed (on c-c, etc.): Manual testing on c-c
Risk to taking this patch (and alternatives if risky): Low risk, style change for menu items (though the change can affect any platform)

Attachment #9352645 - Flags: approval-comm-beta?

Comment on attachment 9352645 [details]
Bug 1852732 - Don't modify menu item background color. r=#thunderbird-front-end-reviewers

[Triage Comment]
Approved for beta

Attachment #9352645 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9352645 [details]
Bug 1852732 - Don't modify menu item background color. r=#thunderbird-front-end-reviewers

[Approval Request Comment]
Regression caused by (bug #): bug 1828413
User impact if declined: Context menu items in settings (and possibly other places) can be unreadable when hovered
Testing completed (on c-c, etc.): Tested on c-c and beta 118.0b5
Risk to taking this patch (and alternatives if risky): low risk, small CSS change

Attachment #9352645 - Flags: approval-comm-esr115?

Comment on attachment 9352645 [details]
Bug 1852732 - Don't modify menu item background color. r=#thunderbird-front-end-reviewers

[Triage Comment]
Approved for esr115

Attachment #9352645 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: