Closed Bug 1854536 Opened 7 months ago Closed 6 months ago

Temporarily disable some Tier 2 a11y_checks for Customizable UI

Categories

(Firefox :: Settings UI, task, P3)

task

Tracking

()

RESOLVED FIXED
120 Branch
Tracking Status
firefox120 --- fixed

People

(Reporter: ayeddi, Assigned: ayeddi)

References

Details

(Keywords: access)

Attachments

(1 file)

We are working on enabling Tier 2 a11y-checks to ensure our products have basic accessibility built-in (bug 1692110) and before that, we need to prepare the existing code base. While we triage and investigate existent tests that would fail once the a11y-checks are enabled in the CI, we are going to skip the failing tests altogether and then handle each one of them individually.

This task is to skip with fail-if condition of the failing tests while we continue investigation into the reasons these tests failed and to be able to backtrack these tests once they're resolved. A separate task to investigate the failed Tier 2 a11y_checks will be filed for an appropriate component.

Tests affected:

Result	Path	Error	Element ID	Element tagName	Element className
FAIL	browser/components/customizableui/test/browser_940307_panel_click_closure_handling.js	Node is not focusable via the accessibility API	browser_946166_button_disabled	toolbarbutton	
FAIL	browser/components/customizableui/test/browser_981418-widget-onbeforecreated-handler.js	Interactive elements must be labeled	test-981418-widget-onbeforecreated	toolbarbutton	toolbarbutton-1 chromeclass-toolbar-additional
FAIL	browser/components/customizableui/test/browser_create_button_widget.js	Interactive elements must be labeled	test_dynamically_created_button	toolbarbutton	toolbarbutton-1 chromeclass-toolbar-additional
FAIL	browser/components/customizableui/test/browser_PanelMultiView_focus.js	Interactive elements must be labeled		toolbarbutton	
FAIL	browser/components/customizableui/test/browser_PanelMultiView_focus.js	Interactive elements must be labeled		toolbarbutton	
FAIL	browser/components/customizableui/test/browser_PanelMultiView_focus.js	Interactive elements must be labeled		toolbarbutton	
FAIL	browser/components/customizableui/test/browser_PanelMultiView_keyboard.js	Interactive elements must be labeled	moz-toggle-button	button	toggle-button
FAIL	browser/components/customizableui/test/browser_panelUINotifications_multiWindow.js	Node is not focusable via the accessibility API		button	popup-notification-primary-button primary panel-footer-button
FAIL	browser/components/customizableui/test/browser_synced_tabs_menu.js	Node is not accessible via accessibility API	PanelUI-remotetabs-connect-device-button	toolbarbutton	PanelUI-remotetabs-button

Jobs affected:

  1. test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-a11y-checks-${1-7} (Try run)

Some Tier 2 accessibility checks for click events fired on controls that should be keyboard accessible and have valid labels were failing for this component. They were captured by testing/mochitest/tests/SimpleTest/AccessibilityUtils.js via bug 1692110. These failing tests should be temporarily skipped in the directory's browser.ini file while we investigate these failures. For all confirmed bugs individual defects should be filed.

When the individual test failures are resolved and the individual bugs are closed, remove the fail-if condition for a11y_checks from the appropriate files/sections to ensure better test coverage and to avoid regressions in a11y of these components.

Blocks: 1854537

We are working on enabling Tier 2 a11y-checks to ensure our products have basic accessibility built-in (bug 1692110) and before that, we need to prepare the existing code base. While we triage and investigate existent tests that would fail once the a11y-checks are enabled in the CI, we are going to skip the failing tests altogether and then handle each one of them individually.

This task is to skip with fail-if condition of the failing tests while we continue investigation into the reasons these tests failed and to be able to backtrack these tests once they're resolved.

Related bugs:

  • Disabling tests: meta bug 1848402
  • Investigation and remediation for components with disabled tests: meta bugs 1848394 and 1854227, component-specific meta bug 1854537
  • Explore capturing click events for a11y_checks: bug 1692110

Depends on D188925

Attachment #9354487 - Attachment description: WIP: Bug 1854536 - Temporarily disable some Tier 2 a11y_checks for Customizable UI. r=Gijs!,Jamie → Bug 1854536 - Temporarily disable some Tier 2 a11y_checks for Customizable UI. r=Gijs!,Jamie
Pushed by ayeddi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bd3f3cb434a5
Temporarily disable some Tier 2 a11y_checks for Customizable UI. r=Gijs
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 120 Branch
Attachment #9354487 - Attachment description: Bug 1854536 - Temporarily disable some Tier 2 a11y_checks for Customizable UI. r=Gijs!,Jamie → Bug 1854536 - Temporarily fail-if some Tier 2 a11y_checks for Customizable UI. r=Gijs!,Jamie
Pushed by ayeddi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/688a863db66e
Temporarily fail-if some Tier 2 a11y_checks for Customizable UI. r=Gijs
Status: REOPENED → RESOLVED
Closed: 6 months ago6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 120 Branch
Flags: needinfo?(ayeddi)
See Also: → 1858041
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: