[FEATURE]Need "Add to Address Book" menu item in envelope context menu

VERIFIED FIXED in M16

Status

MailNews Core
Backend
P2
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: fenella, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: 2 days)

(Reporter)

Description

19 years ago
Based on this spec
http://gooey/client/5.0/specs/mail/messenger/messenger.html#Envelope

It will have a "Add to Address Book" icon right next to the From field.
This  bug tracks the implementation of this feature

Updated

19 years ago
Assignee: phil → rhp

Comment 1

19 years ago
Reassign to rhp

Comment 2

19 years ago
Actually, the button is there, and it calls into JavaScript, but I need a
function that will allow me to access an Add Person dialog from JS.

Paul: We talked about this a long time ago...is it in place yet?

- rhp
Status: NEW → ASSIGNED
Target Milestone: M13

Updated

19 years ago
Blocks: 10791
QA Contact: lchiang → esther

Updated

19 years ago
Assignee: rhp → hangas
Status: ASSIGNED → NEW

Comment 3

19 years ago
Hi Paul,
I'm throwing this one your way since my side is all done and I need a way from
JavaScript to put up an add user dialog for the address book. Let me know if
you have any questions.

- rhp

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 4

19 years ago
Marking asap

Updated

19 years ago
Target Milestone: M13 → M14

Comment 5

19 years ago
M14 since Paul is out sick

Comment 6

19 years ago
Here you go Scott.
Assignee: hangas → mscott
Status: ASSIGNED → NEW
Target Milestone: M14
(Assignee)

Comment 7

19 years ago
*** Bug 26231 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Target Milestone: M14
(Assignee)

Comment 8

19 years ago
This also means hooking up the menu popup.
(Assignee)

Comment 9

19 years ago
*** Bug 26230 has been marked as a duplicate of this bug. ***

Comment 10

19 years ago
From the cvs comment:
> turn on the address book collector for email addresses in the message pane.
> For every From field we encounter, we'll add the address to the collection
> address book.

I really don't like this behaviour. I don't want spammer addresses in my address
book. Can I turn it off?
(Assignee)

Comment 11

19 years ago
Hey Ben, this bug is talking about a menu item where you say add sender to
address book. I think you are talking about the ab collector which is Bug #23362
. I accidentally wrote the wrong bug number down in my checkin comment. We
should follow anything else up in that bug.

To answer your question about that though, you can set
mail.collect_email_address to false in your prefs.js file to turn off auto
collection.
(Assignee)

Comment 12

19 years ago
*** Bug 29203 has been marked as a duplicate of this bug. ***

Comment 13

19 years ago
*** Bug 31305 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 14

19 years ago
Moving my remaining M14 bugs to M15 which is the next targeted milestone.
Target Milestone: M14 → M15

Updated

19 years ago
Whiteboard: 2 days

Comment 15

19 years ago
Syncing priority with marketing.  Moving to P2 to connote "In" for beta2.
Priority: P3 → P2

Comment 16

19 years ago
move to M16.  Not M15 stoppers
Target Milestone: M15 → M16

Comment 17

18 years ago
should this be nsbeta2, scott?  
(Assignee)

Comment 18

18 years ago
Yes it should...I forgot about this feature....yuck...
Keywords: nsbeta2
(Assignee)

Comment 19

18 years ago
In addition I'd like to just get rid of the Add to Address Book button
completely and rely on the context menu entry for Add to Address Book....
(Assignee)

Comment 20

18 years ago
I have a quick and dirty version of this working. I modified abCardOverlay.js so
you can pass it arguments it will use to initialize the window with.

Right now, add to address book from the message pane will bring up a new card
dialog and will prefill ONLY the display name and email address fields.

I haven't figured out how to get it to add the aim screen name yet. My changes
to abCardOverlay.js are extensible so we can easily add as many arguments as
there are properties on an address book card.

I'll check this in tonight. Oh, I also got rid of the redundant add to address
book button. We can put it back if I'm in the minority.
Summary: [FEATURE]Need "Add to Address Book" Button(or icon) in envelope → [FEATURE]Need "Add to Address Book" menu item in envelope context menu
(Assignee)

Comment 21

18 years ago
fixed. See my comments above for specifics about the intended behavior.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 22

18 years ago
> will prefill ONLY the display name and email address fields.



4.x recognized the given and Surname and field those fields as well. Shouldn't

we do this in Mozilla as well?

Comment 23

18 years ago
Using build 2000-05-16-09 on win and linux the context menu is working as 
described in comments 2000-05-15 22:10.  Mac isn't working for all context menus 
so I can't verifiy this on Mac.  Also, UI spec still shows the "Add to Address 
Button", cc'ing jglick for comment on it's removal.  Scott if this button was 
removed for pr2 only and will be put back when time permits, please update and 
I'll log a new bug for putting it back.   

Comment 24

18 years ago
Update: Mac context menu works too, Note:because of bug 18726 to get the context 
menu for mac you have to use Ctrl+Click.

Comment 25

18 years ago
The summary of this bug references the Context menu, which is fixed.  The 
scenario references the "Add to Address Book" button, which was removed.  I will 
verify this as a context menu bug that is fixed.  I will log a new one for the 
misssing button if Jennifer wants it back in.  Verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.