Closed Bug 1859938 Opened 7 months ago Closed 7 months ago

Mail forwarding of multiple messages broken in v115.3.1esr

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 115
defect

Tracking

(thunderbird_esr115? fixed)

RESOLVED FIXED
120 Branch
Tracking Status
thunderbird_esr115 ? fixed

People

(Reporter: ladar, Assigned: welpy-cw)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0

Steps to reproduce:

I recently updated from 102.15.1 to 115.3.1 and noticed the broken behavior.

For starters I have mail.forward_message_mode=0 ... this means I forward messages as attachments by default.

Before ny upgrade, I could select any number of messages, press Cntrl+L, and then forward the selected messages as an attachment.

After upgrading, this functionality continues to work, but only if a single message is selected. If I have multiple messages selected, and press Cntrl+L, nothing happens.

Actual results:

Nothing happens when multiple messages are selected, and I press Cntrl+L.

If I press the forward button, the messages will get forwarded inline. If multiple messages were selected, then multiple compose windows appear, with a single inline forward for each.

Changing the value of mail.forward_message_mode to 1 or the default 2, has no affect. Nothing happens when multiple messages are selected and I press Cntrl+L.

Expected results:

An empty composition window should appear, and all of the messages that are selected, whether it be 1 or 18,564 should be attached to that message.

I believe the new version is ignoring the pref flag, and doing nothing when multiple messages are selected. This makes sense as a default behavior when inline attachments are the default style.

Personally I have always believed that if multiple messages are selected, and a user hits forward, a mail agent should forward them as attachments. If a user has expressly selected inline as their preferred default, then popping open multiple compose windows makes sense. Likewise, if a user selects as an attachment as the preferred mode, then a single compose with the message(s) attached makes sense.

Either way, please restore the old behavior. I use the Cntrl+L short cut to forward my junk mail to various places, as attachments, on a daily (as in multiple times per day) basis. And I don't know if you know this already, but my junk mail is very social, and doesn't like to be forwarded one message at a time. It prefers to travel as a group.

Status: UNCONFIRMED → NEW
Component: Untriaged → Folder and Message Lists
Ever confirmed: true
Keywords: regression
Regressed by: 1735119

I can confirm this regression. Until this is fixed, using [Shift]+[F10] [o] should still work.

Summary: Mail forwarding w messages broken in v115.3.1esr → Mail forwarding of multiple messages broken in v115.3.1esr
Assignee: nobody → h.w.forms
Status: NEW → ASSIGNED
Target Milestone: --- → 120 Branch

Pushed by solange@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/596ad9d8fa8e
Re-enable forwarding by hotkey for multiple messages. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED

Comment on attachment 9359331 [details]
Bug 1859938 - Re-enable forwarding by hotkey for multiple messages. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): 1735119
User impact if declined: Hotkey doesn't work as expected.
Testing completed (on c-c, etc.): c-c and beta
Risk to taking this patch (and alternatives if risky): very low

Attachment #9359331 - Flags: approval-comm-esr115?
Attachment #9359331 - Flags: approval-comm-beta?
Attachment #9359331 - Flags: approval-comm-beta?

Comment on attachment 9359331 [details]
Bug 1859938 - Re-enable forwarding by hotkey for multiple messages. r=mkmelin

[Triage Comment]
Approved for esr115

Attachment #9359331 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: