Closed Bug 1860885 Opened 9 months ago Closed 9 months ago

All Mail and Calendar items are missing in 119, works fine downgrading to 118. cmd_fullZoomToggle command: [Exception... "[JavaScript Error: "webBrowser is undefined" about3Pane.js

Categories

(Thunderbird :: Folder and Message Lists, defect, P1)

Thunderbird 119

Tracking

(thunderbird_esr115+ fixed, thunderbird120+ fixed)

RESOLVED FIXED
121 Branch
Tracking Status
thunderbird_esr115 + fixed
thunderbird120 + fixed

People

(Reporter: silverbacknet, Assigned: mkmelin)

References

Details

(Keywords: regression)

Attachments

(6 files)

Attached file tb119.console.log

Steps to reproduce:

Upgraded from 118b6 to 119. (b3, b4, and b6 all the same so far)

Actual results:

Nothing appears inside the folder and message panes, no calendar entries show (local or Google), even in Troubleshooting Mode. The only hint that the profile is actually loading is the Calendars are all listed, without the entries. Downgrading to 118 with the profile downgrade switch restores full functionality.

I've attached a console log and screenshots, in case that helps.

Expected results:

Everything appears as normal.

Attached image tb119.mailpanel.png
Attached image tb119.calendar.png

We have some other examples: bug 1853022, bug 1857223

Flags: needinfo?(mkmelin+mozilla)
Keywords: regression
See Also: → 1853022, 1857223
Summary: All Mail and Calendar items are missing in 119, works fine downgrading to 118 → All Mail and Calendar items are missing in 119, works fine downgrading to 118. cmd_fullZoomToggle command: [Exception... "[JavaScript Error: "webBrowser is undefined" about3Pane.js
Severity: -- → S2

How is 120? Bug 1857223 was not fixed for 119 betas.

Flags: needinfo?(mkmelin+mozilla)

Same symptom in 120b1, but the logs have changed. New exception: cmd_print command: [Exception... "[JavaScript Error: "accountCentralBrowser is undefined"

Attached file tb120b1.console.log

I found a way I could reproduce at least part of this. If I start with thunderbird -purgecaches -jsconsole some timings are different due to the console starting up.

console.error: "An error occurred updating the cmd_stop command: [Exception... "[JavaScript Error: "can't access property "busy", webBrowser is undefined" {file: "chrome://messenger/content/about3Pane.js" line: 7050}]'[JavaScript Error: "can't access property "busy", webBrowser is undefined" {file: "chrome://messenger/content/about3Pane.js" line: 7050}]' when calling method: [nsIController::isCommandEnabled]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: chrome://messenger/content/globalOverlay.js :: getEnabledControllerForCommand :: line 61" data: yes]"

Uncaught TypeError: can't access property "contentWindow", win.messageBrowser is undefined
openTab chrome://messenger/content/mailTabs.js:100
_cloneTemplate chrome://messenger/content/mailTabs.js:66
mailTabs.js:100:13
openTab chrome://messenger/content/mailTabs.js:100
_cloneTemplate chrome://messenger/content/mailTabs.js:66

Assignee: nobody → mkmelin+mozilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9360367 - Attachment description: Bug 1860885 - Fix more cases of getting blank 3pane due to not yet defined browsers. r=#thunderbird-reviewers → Bug 1860885 - Fix more cases of getting blank 3pane due to not yet defined browsers. r=john.bieling

There is still on the log, Uncaught (in promise) NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgFolder.server] which wouldn't be fixed by the patch above. Unclear if that's due to an add-on or not (try Troubleshoot mode).

Target Milestone: --- → 121 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/6dce4e7ce67f
Fix more cases of getting blank 3pane due to not yet defined browsers. r=john.bieling

Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Priority: -- → P1

Comment on attachment 9360367 [details]
Bug 1860885 - Fix more cases of getting blank 3pane due to not yet defined browsers. r=john.bieling

[Triage Comment]
Approved for beta

Attachment #9360367 - Flags: approval-comm-beta+

Comment on attachment 9360367 [details]
Bug 1860885 - Fix more cases of getting blank 3pane due to not yet defined browsers. r=john.bieling

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined: Looks like your mail folders are empty!
Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky):
Unsure, looks reasonably safe. This issue has been declared "fixed" on esr115 before, worst case this doesn't completely work.

Attachment #9360367 - Flags: approval-comm-esr115?

Comment on attachment 9360367 [details]
Bug 1860885 - Fix more cases of getting blank 3pane due to not yet defined browsers. r=john.bieling

[Triage Comment]
Approved for esr115

Attachment #9360367 - Flags: approval-comm-esr115? → approval-comm-esr115+

Unfortunately, I cannot confirm the fix in TB 120b3, with or without Troubleshooting Mode. The log is much shorter this time! But still with the error and same symptom.

Attached file tb120b3.console.log

Yes that part is not addressed by the above patch. Probably it's bug 1857824. Could you check your prefs.js? Feel free to send it to me is you like.

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: