Closed Bug 1864203 Opened 7 months ago Closed 2 months ago

Gmail Calendar account detection do not work for google hosted domain if the host's DNS has google hostnames UPPERCASEed

Categories

(Thunderbird :: Account Manager, defect)

Thunderbird 115
defect

Tracking

(thunderbird_esr115 wontfix)

RESOLVED FIXED
126 Branch
Tracking Status
thunderbird_esr115 --- wontfix

People

(Reporter: antonio.mario.caruso, Assigned: mkmelin)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/119.0.0.0 Safari/537.36

Steps to reproduce:

Install Thunderbird.
Create two email profile for two different gmail and working email account (the working account is a business account that professional gmail service with my university domain (unisalento.it).
Add a calendar in calendar view. Insert gmail username, inserted the same username for 'address', NO RESULT.
-> Find Calendar do not find anything.

Actual results:

Find Calendar do not find anything.

Expected results:

When I configure a gmail email account, and email sync is already working (so I configured the password and authorization for email), in calendar pushing 'add calendar' MUST 3 options

  1. local calendar or ical file
  2. network calendar
  3. calendar of the account:
    • configured gmail account 1
    • configured gmail account 2
      ...
      so I just click on the account, and I get the list of calendar to sync, or better, sync all calendar and eventually have a preference panel to select the sync options for each calendar (like the folder options in imap).

It is generally working.
When you say username, do you do give the full gmail address?

Same or similar issue here. I can connect to my Google calendar, and all of the automatically generated sub-calendars within are displayed (holidays, birthdays). But the events in the main calendar are mostly not there, baring some exceptions from last month.

Additionally, I can create events in Thunderbird, which are synchronized to my Google calendar and show up there, on my phone and so on. But they do not show up in Thunderbird.

So I found a solution to my problem: In the folder /Profiles/.../calendar-data I removed the files 'cache.sqlite' and 'deleted.sqlite'.

Thunderbird recreated the files and. After another calendar synchronisation the calendar events all show up. For the momnet everything seems to be working as expected.

Hi Antonio,

I can confirm that adding a Gmail Mail account in Thunderbird, does not automatically allow to find and select Gmail calendars as per your Comment 0 Expected Results option 3. That would be a nice addition, either as an option during initial setup of mail account or afterwards while adding a new calendar :-)

(In reply to Antonio Caruso from comment #0)

Add a calendar in calendar view. Insert gmail username, inserted the same username for 'address', NO RESULT.

Try the following steps instead:

  • New Calendar...
  • On the network
  • Next
  • In the User Name field, type your Gmail address with the @ domain e.g richard@gmail.com
  • By doing so, the Location is auto-completed by Thunderbird and set to gmail.com, leave it as pre-set.
  • Find Calendars

That should allow you to list your Gmail calendars and select those you want to access via Thunderbird.

For me, it seems to be working in both TB 115.9.0 (64-bit) Release Channel and TB 124.0b4 (64-bit) Beta Channel with new profile created with two Gmail Mail accounts. I can add and access any calendars from any accounts ones the above steps are completed. I am not asked to authenticate either which is handy.

Detailed steps:
https://www.zdnet.com/home-and-office/work-life/how-to-add-a-google-calendar-to-thunderbird/

Cheers,
Richard,

In the case of unisalento.it these are like ALT2.ASPMX.L.GOOGLE.COM

Assignee: nobody → mkmelin+mozilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9393568 - Attachment description: Bug 1864203 - Detect google CalDAV/CardDAV even if DNS MX records have UPPERCASE hostnames. r=#thunderbird-reviewers → Bug 1864203 - Make resolved DNS results hostnames lowercase, and make the DNS worker a module worker. r=darktrojan
Summary: Gmail Calendar account do not work. → Gmail Calendar account detection do not work for google hosted domain if the host's DNS has google hostnames UPPERCASEed
Target Milestone: --- → 126 Branch
See Also: → 1888115
See Also: 1888115

Pushed by martin@humanoids.be:
https://hg.mozilla.org/comm-central/rev/119177ebbaf0
Make resolved DNS results hostnames lowercase, and make the DNS worker a module worker. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: